Page MenuHome

Subdivision modifier slower than Blender2.79 non-OpenSubDiv in edit mode
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: Radeon RX 580 Series ATI Technologies Inc. 4.5.13571 Core Profile Context 19.9.2 26.20.13003.1007

Blender Version
Broken: version: 2.81 (sub 15), branch: master, commit date: 2019-10-12 15:33, hash: rB95f020c853d6
Worked: Blender 2.79

I created this bug report at Sergey's request in devtalk.

Short description of error
Blender Subdivision modifier slower in different edit modes compare with blender2.79 Non-OpenSubDiv subdivision, No matter if the mesh is created entirely from quads, triangles or ngons. also it appear that needs a "start" time to activate the subdivision or when you move the vertex, something that didn't happen with 2.79 subdivision.

  • edit quad mesh with subdivision
  • edit lattice for an object with subdivision

Exact steps for others to reproduce the error
Open the shared files to test different conditions. The results in my test are

EDIT MODE mesh with quads

  • 2.79: 50fps
  • 2.80: 10fps

Lattice

  • 2.79: 19fps
  • 2.80: 10fps

Armature mesh only with quads

  • 2.79: 4,5fps
  • 2.80: 6 fps

Also I provided other mesh file that show strange behaviors that I comment in next comment.

This problem is a extreme regression since it made impossible to work with blender2.80 with hard-surfaces, animation characters,... Specially when the undo-Z can need 4-5 seconds only when the scene have some subdivision objects and this problem disappear when you deactivate the subdivision.

Details

Type
Bug

Event Timeline

Side effects of the actual subdivision.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.

Also I provided other mesh file that show strange behaviors that I comment in next comment.

Please never report two issues under the same task. Make a separate one for this.
Also try to explain what exactly wrong in a plain text. Simply uploading videos doesn't add that much value.

The edit mode performance i'll have a look into.

@Sergey Sharybin (sergey) I have two CPUs, intel i7 4790 and amd ryzen 3700x, videos recorded in the Ryzen. I can also test it in other intel i7 and a old quad core.

There are some threading scheduler issues i've found. Working on solving them.
This isn't limited to the edit mode though (at least not as long as topology stays the same).