Page MenuHome

Object Wireframe disappear when armature bone is selected in edit mode
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: Darwin-17.2.0-x86_64-i386-64bit 64 Bits
Graphics card: NVIDIA GeForce GTX 1050 Ti OpenGL Engine NVIDIA Corporation 4.1 NVIDIA-10.27.6 378.10.10.10.20.109

Blender Version
Broken: version: 2.82 (sub 0), branch: master, commit date: 2019-10-14 19:07, hash: rB9a85592ddea2
Worked: (optional)

Short description of error
If you have the wires visible on a mesh object and then select a bone in edit mode on an armature object, the wireframe disappears.
This makes it hard to position the bones effectively.

This may be related to https://developer.blender.org/T67831 as it occurs under the same circumstances as when the navigation icons disappear.

Exact steps for others to reproduce the error
add mesh object and enable wires in viewport visibility
add armature
switch to edit mode for that armature
as soon as you select a bone - the wires on the mesh object are no longer visible

Details

Type
Bug

Related Objects

Event Timeline

Jacques Lucke (JacquesLucke) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.Tue, Oct 15, 9:51 AM

I agree that might be related T67831. I cannot reproduce it because I don't have macOS.

I might have found a related problem in Blender 2.81 beta on Mac OS X, Graphic Card: Intel Iris Graphics 6100. When selecting a bone in Editmode ALL MESHES disappear (and the viewport navigation icons as well)

I can reproduce and confirm the behavior of the original report.
with the wire_frame_not_visible.blend file in blender 2.81 beta.
Wireframe and navigation Icons dissapear when selecting bone in editmode.

I just found out, that disabeling "outline" in the viewport shadeing dropover, makes the whole mesh disappear. That was my initial problem.