Page MenuHome

Masking tools was a bug after Undo
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1060 6GB/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86

Blender Version
Broken: version: 2.81 (sub 15), branch: master, commit date: 2019-10-15 17:59, hash: rBcfb6ffd48f77
Worked: (optional)

Short description of error
Expand mask was a bug after Undo

Exact steps for others to reproduce the error
In Sculpt mode

  1. Shift+A or Shift+Alt+A for expand some mask
  2. Press Ctrl+Z for undo
  3. Try to sculpt for all area of mesh, brush affect slupture on more area than mask was select, but not all.

Masking with Box Mask tool has same bug. Mask Brush work normally after Ctrl+Z.
For manually fix it, change Sculp mode, If after masking press Alt+M, sculp mode work correctly.

Event Timeline

Jacques Lucke (JacquesLucke) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Wed, Oct 16, 4:04 PM

I do not understand how to reproduce the bug. Please provide a very simple .blend file with as few steps as possible to make it easier to reproduce.

Oh my mistake, in my .blend file i use defaul cube but with huge amout of polygons.

  1. At start Blender, you can select default box, and go to squlpt mode.
  2. Use Remesh with Voxel size 0.01m it make cube with 484K of triangles.
  3. And then, Shift+A or Shift+Alt+A for expand some mask
  4. Press Ctrl+Z for undo
  5. Try to sculpt for all area of mesh, brush affect slupture on more area than mask was select, but not all.

Aftre all my sculpt work like on screen below.

Jacques Lucke (JacquesLucke) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Wed, Oct 16, 5:45 PM
Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Thu, Oct 17, 5:03 PM