Page MenuHome

Unexpected Behavior - Smoke domain does not match viewport container
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce RTX 2080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.15

Blender Version
Broken: version: 2.81 (sub 11), branch: master, commit date: 2019-09-16 21:02, hash: rB76650402f300
Worked: (optional)

Short description of error
When the domainobject is modified in edit mode the domain calculation does not follow
I dont know how to say that but - "The Code Under the Hood" seems not to recognize this.

Exact steps for others to reproduce the error

  • Create a cube
  • go to edit mode
  • move verticies around -> e.g. Bottom to Zero instead of -1 and top to 2 instead of 1
  • leave edit mode and for savety apply trandformations
  • go to Physics Tab and make a domain out of the cube
  • add flow object press Play and play a few frames
  • turn on Debug Velocity
  • Velocity is not matching smoke visualization in vieport

it seems that recentering the Pivot fixes that

[Based on the default startup or an attached .blend file (as simple as possible)]

Details

Type
Bug

Event Timeline

Might be related to T70678, not sure.

Jacques Lucke (JacquesLucke) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Wed, Oct 16, 3:20 PM

Don't know if this is the same issue, but I can confirm the issue described here.

  1. Open the file.
  2. Play the animation.

Jupp - Looks the same.
if you now center the origin, ist gone.

I can confirm.
As seen in the image attached by @Jacques Lucke (JacquesLucke), the needles indicating speed are partially out of the domain.

I can take a look at this one. Is more in my alley than the fragment shader

Cause is inside the volume_velocity_vert.glsl here it is assumed that the velocity texture has to be drawn around the center of the object.

vec3 pos = (vec3(cell_co) + 0.5) / vec3(volume_size);
pos = pos * 2.0 - 1.0;

We should add an offset that has been calculated from the bounding box of the object cq mesh, currently checking if the the SmokeDomainSettings already has needed data.

is the worst case situation. Note that the voxel size debug cube is correct (due to D6076).

Object scale + pivot transform needs to be fixed.

Voxel size is also incorrect (visible when enabling adaptive domains)

Clément Foucault (fclem) closed this task as Resolved.Tue, Oct 29, 5:39 PM

This seems to have been fixed.