Page MenuHome

Cycle Optix fails or crashes on viewport render
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce RTX 2070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.30

Blender Version
Broken: version: 2.82 (sub 1), branch: master, commit date: 2019-10-18 14:43, hash: rB3de44469593a
Worked: (optional)

Short description of error
Cycles Optix rendering on the viewport fails or crashes Windows 10. System console error:
OptiX CUDA error CUDA_ERROR_LAUNCH_FAILED in cuStreamSynchronize(cuda_stream[thread_index]), line 824
OptiX CUDA error CUDA_ERROR_ILLEGAL_ADDRESS in cuStreamSynchronize(cuda_stream[thread_index]), line 824

F12 render image works fine and yesterday's build works fine. It is probably related to yesterday Cycles commit from Optix.

Exact steps for others to reproduce the error
To reproduce on default startup open Blender in preferences make sure Optix is selected. Switch render to Cycles and GPU Compute and now enable viewport rendering.

Event Timeline

I have the same problem on Arch.
Also Blender is crashing in both ways:

  1. Enable Viewport render > error> go to settings > switch to CUDA > Crash.
  2. Enable Viewport render > error> F12 > Crash.

OptiX CUDA error CUDA_ERROR_ILLEGAL_ADDRESS in cuStreamSynchronize(cuda_stream[thread_index]), line 824
OptiX error OPTIX_ERROR_INVALID_DEVICE_CONTEXT in optixDeviceContextCreate(cuda_context, &options, &context), line 250

Brecht Van Lommel (brecht) lowered the priority of this task from Needs Triage by Developer to Confirmed, High.

Same issue on Windows 10 1903 + RTX 2070 here. CUDA is fine and F12 render is fine, viewport render with OptiX does not work. Tried both 436.30 and 436.48 drivers.

Patrick,

The fix was committed only to the release 2.81 branch, also please merge fix to the master.

Sorry, forgot. Done now!