Page MenuHome

blender 2.8 freezes on various occasions
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: amd radeon r7 200 series (2gb vram)

Blender Version
Broken: latest 2.8 version from the blender homepage
Worked: 2.7

i started using blender 2.8 when it was in beta and it was freezing a lot for me on various occasions, so i decided to stick with 2.7 thinking that it was too early to use it and it's in a bad state yet. just recently i got the latest 2.8 version and to my surprise it still freezes. i managed to narrow down the problem and i got this project file, where if i'll do a few loop cuts (ctrl+R), and do something with a knife tool a few times, i get a freeze and then crash with a windows' "not responding" error, and i can do this consistently. to note i do evertyhing in default "Solid" render mode, not using evee or lookdev{F7841240}

Event Timeline

Unable to crash your file. May be it is hardware/OS specific? Did you tried Memtest? Latest graphics drivers? Does other apps freezing or crashing? Can you try on another PC?

Well i figured that others wouldn't get the same bug, i tried searching but looks like i might be the only one getting this. I'm quite sure my hardware is working properly, i use this computer every day, i play modern games on it and don't have any problems. so when the freeze happens everything on my computer freezes for like a couple of seconds (but i can still move my cursor and hear sound from other programs), and after that everything continues to work except blender ofc, it's just frozen and not responding until i force-close it. all the drivers are latest. i wonder if there is a way to log everything happening with blender to see what exactly happens on the freeze?

you forgot to fill relevant data as request in bug template

The operating system, main memory size, GPU brand and model, GPU driver version and Blender hash or its build date may be needed by developers to investigate this problem

make a clean update of your GPU drivers from Amd support site can solve/mitigate this problem, latest Amd drivers avaible for your GPU is Adrenalin 19.10.1
unplug all USB device (as tablet, exotic pointer, etc..), reset blender to factory setting and reload your test file with LoadUI option disabled, after this you can make a new test to confirm this problem

Thank you

Germano Cavalcante (mano-wii) lowered the priority of this task from 90 to 30.Oct 21 2019, 4:52 PM

A similar problem has been reported before.
An unofficial addon was causing the problem.
Can you reproduce the problem after restoring factory settings?

Also make sure the same happens with the latest builds:
https://builder.blender.org/download/

So i tried this build: blender-2.81-388c954cb537-windows64, with all of the factory settings. after like 12 mins of work i got the same problem. Again, all of my drivers are latest, i have no exotic controllers plugged in. My PC specs are: Win 10, 16 gb of RAM, amd radeon r7 200 series GPU (2gb vram), i7-7700k CPU

Could you provide the system_info.txt (Help -> Save System Info).

This sounds more like a problem with your computer.
You can also try this: https://answers.microsoft.com/en-us/windows/forum/windows_10-update/system-file-check-sfc-scan-and-repair-system-files/bc609315-da1f-4775-812c-695b60477a93

Germano Cavalcante (mano-wii) raised the priority of this task from 30 to 80.Nov 1 2019, 6:29 PM
Richard Antalik (ISS) changed the task status from Needs Developer to Reproduce to Needs Information from User.Jan 15 2020, 3:44 PM

Is this still an issue with latest build? https://builder.blender.org/download/

Richard Antalik (ISS) closed this task as Invalid.Jan 23 2020, 1:43 AM
Richard Antalik (ISS) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to close the report.