Page MenuHome

UV image get lighter and lighter until gets white when selected UVs are in the same area
Closed, ArchivedPublic

Description

Blender Last source compiled.
Windows 10
NVIDIA RTX2080TI

When you have several UVs using the same space in the texture, you get lighter and lighter color until you get full white.

Test File:

Details

Type
Bug

Event Timeline

Antonio Vazquez (antoniov) renamed this task from UV image get lighter and lighter until gets white when select several UVs are in the same area to UV image get lighter and lighter until gets white when selected UVs are in the same area.Oct 21 2019, 11:43 AM
Antonio Vazquez (antoniov) created this task.
Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.Oct 21 2019, 11:54 AM

Hm, not sure this is a "real" bug, doesnt seem like the actual image is getting brighter, it is just the face overlay drawing with a bit of alpha that adds up the more faces are on top of each other.
(will quickly check if another blend mode could help here...)

Not exactly sure if there is an easy workaround for this?
[same thing can happen to you if you stack lots of faces in the 3DView as well btw. ...]

CC @Jeroen Bakker (jbakker)
CC @Clément Foucault (fclem)

@Philipp Oeser (lichtwerk) I checked in 2.79 and is working equals. It looks there are some alpha cumulative effect. Not sure if this can be fixed, but it's weird to miss the texture and get a white box.

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Nov 6, 4:20 PM
Brecht Van Lommel (brecht) claimed this task.

Not a bug, feel free to developer a better drawing method if you want.