Page MenuHome

Panoramas as textures cause crash
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: Radeon RX 580 Series ATI Technologies Inc. 4.5.13571 Core Profile Context 19.9.2 26.20.13003.1007
Processor: i5-9400F
RAM: 16GB

Blender Version
Broken: version: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e
Worked: (optional)

Short description of error
Attempted to use a panoramic image as a texture on an object, but Blender crashed immediately when trying to render. Crash occurs with or without other objects in the scene.

Exact steps for others to reproduce the error
Image taken on Galaxy S9 (Panoramic image, 4000 by 4016 pixels, JPG file, about 7 MB) -> Import over USB to PC -> Use image as a texture (I tried a cube, a plane, and through the "Import Images As Planes" option) -> Render in Cycles -> Immediate crash

Details

Type
Bug

Event Timeline

Just realized I forgot to pack the image with the .blend file. Did that, and tested it and it renders without crashing when the image is packed with it. Here's the packed file anyway.

Doesn't crash with GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86.

It's just a .jpg image, the fact that it's a "panorama" shouldn't matter. Also this image doesn't look very panoramic to me, by the way.

You can try with latest build from https://builder.blender.org/download/ and see if it crashes.

Edit: Ok, as @Philipp Oeser (lichtwerk) wrote below, if I unpacked the image it crashed.

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Tue, Oct 22, 11:26 AM

Can actually confirm that (if I unpack the image into //window2.jpg and then render with F12)
libjpeg complaining: Invalid SOS parameters for sequential JPEG then something going wrong with the filename

Lets see if we can safeguard this.

Lol, I accidentally added Philipp Kant (philipp) as a subscriber even though I wrote Philipp Oeser. Should have wrote username alone I guess.

I think this is not the first time this happened [sorry for this @Philipp Kant (philipp) ... but also not sure how to prevent it...], will remove you as subscriber again...

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Nov 6, 7:12 PM
Brecht Van Lommel (brecht) claimed this task.

This will be fixed when we upgrade to the latest OpenImageIO, it's not a bug in Blender itself.
https://github.com/OpenImageIO/oiio/commit/47404a0