Page MenuHome

Recognized loop on node group while input and output are not conected
Closed, ArchivedPublic

Description

Windows 10

Blender 2.81 beta 95f020c853d6 64-bit{F7847627}

loop recognized on node group when connected output with input(outside the group) while input and output are not connected inside the group

to recreate the bug:
1.in shader editor make node group whit two reroutes.
2.connect one reroute whit input and other whit output(without connecting two points).
3.make another reroute outside the node group.
4.connect input and output of the group to the reroute made in step 3.
and not existing loop will be recognized.

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Wed, Oct 23, 1:06 PM

I can confirm the behavior, but...

Could you elaborate what the usecase is here?
(cant think of anything where a nodegroup output is not dependent on input? -- and if it was, then the loop would make total logical sense)

this is kind of what i need it for(if you understand this)

Brecht Van Lommel (brecht) closed this task as Archived.Wed, Nov 6, 3:06 PM
Brecht Van Lommel (brecht) claimed this task.

It may be useful to support this, but it's a feature request rather than a bug. By design, node groups can be executed in a single step and the node graph makes no assumption about their contents.
https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests