Page MenuHome

make single user not working across scenes
Closed, ArchivedPublic

Description

System Information
Operating system: Windows-10-10.0.17134 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.81 (sub 15), branch: master, commit date: 2019-10-15 17:59, hash: rBcfb6ffd48f77
Worked: (optional)

Short description of error
make single user not working across scenes

Exact steps for others to reproduce the error
open the file and go to scene.002, try and make the far right cube a single user (object), now move the cube in 'scene.002' and go back to 'scene'. The cube has moved in 'scene' too.

now go to 'scene.002' again and this time choose to make single user (object and data), now edit the cube. The cube is also edited in 'scene'

Details

Type
Bug

Event Timeline

Germano Cavalcante (mano-wii) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Thu, Oct 24, 2:35 PM

... try and make the far right cube a single user (object)...

I didn't understand this part. The object is already a single user.

... try and make the far right cube a single user (object)...

I didn't understand this part. The object is already a single user.

Germano Cavalcante (mano-wii) raised the priority of this task from Needs Information from User to Needs Triage by Developer.

@Bastien Montagne (mont29), you must understand this area better.

Your two scenes share the same collection, so obviously the same objects too... You need to make single user of the collections first, then you can do the same for objects.

We do not handle user support on this tracker, only bug reports. User forums like blenderartists.org or blender.stackexchange.com and our devtalk should be used for that matter.

Your two scenes share the same collection, so obviously the same objects too... You need to make single user of the collections first, then you can do the same for objects.
We do not handle user support on this tracker, only bug reports. User forums like blenderartists.org or blender.stackexchange.com and our devtalk should be used for that matter.

I'm not sure you understood. Watch the video where I show it working correctly in 2.8 and then not working in 2.81. PS, making a collection single user returns an error message of 'not yet implemented' in the info bar.

I understood the steps written in report, and answered accordingly. As a reminder, Videos and/or links to external sites etc. are not acceptable as bug report (they can be provided as additional information only).

I understood the steps written in report, and answered accordingly. As a reminder, Videos and/or links to external sites etc. are not acceptable as bug report (they can be provided as additional information only).

Sorry, I'm not sure why you're telling me this. I uploaded a .blend and then later a video for additional information.

Did you watch the video? It shows that I'm following the correct process in both 2.8 and 2.81, but it's only working in 2.8. I'm at a bit of a loss as to how this isn't a bug.

i can confirm on it don't work as it was in past blender versions.. is this redesign? that is now taking place?

if so how we can make object to be unique one instead of linked one. do we have to simply ctrl+c ctrl+v for now? or shift d? instead of right click for example in out liner and make single user?

i mean this is really confusing currently i kinda did report way back with how it is a mess.. and it got approved. but what is the status on this now?

System Information
Operating system: Linux-4.15.0-70-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: GeForce 610M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 390.116

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-15 16:32, hash: rBeba4a4bd73ba

The bug is valid as confirmed also by @Maciej Jutrzenka (Kramon) and myself.

The video was maybe a bit long (only 3 minutes, but could've been maybe a bit more succinct), but it illustrates the steps given in the bug report, contrasting with 2.80 as extra bonus (so others don't have to).

I currently don't see a way to make the collection single user in 2.81, nor does the make single user part on the object and its data work the same as in 2.80.

Nathan Letwory (jesterking) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Mon, Nov 18, 6:58 PM

Bastien on dev.chat said "there is no change here, guy is just using same collections in both scenes, obviously make single user won't do anything, since object is already only used by one collection"

so... considering this new information.. i made new test... 2 scenes TAKE_A and TAKE_B.. TAKE_A have collection TAKE_A and TAKE_B have collection TAKE_B both have same object.. linked toghether as outliner shows.. i am going to outliner and clicking make single user.. to basically just unlink it.. but it dosn't do anything...

yep, that just brings up a message at the bottom saying not yet implemented.

Regarding them both belonging to the same collection, does that mean that in 2.8 when you choose to create a scene as a linked copy, the collection created in the duplicated scene is independent of the collection in the original scene, but in 2.81 the duplicated collection in the second scene is an instance of the original collection? That would explain why in my video above it works as it always has in 2.8, but in 2.81 it doesn't.

well Blender file is a storage. Scenes is only displaying % of data that is avable in that storage.. Collections are one of that thing.

if u have collection called Pikatchu.. And u hve it in both scenes... all this means is that... u have only 1 collection called pikatchu.. and in both scenes u have choosen to display that collection.

well Blender file is a storage. Scenes is only displaying % of data that is avable in that storage.. Collections are one of that thing.
if u have collection called Pikatchu.. And u hve it in both scenes... all this means is that... u have only 1 collection called pikatchu.. and in both scenes u have choosen to display that collection.

but in 2.8 that wasn't the case? Can't understand why it was working in 2.8 as it had in 2.79b, but in 2.81 it no longer is. Especially if Bastien is saying nothing has changed.

Dalai Felinto (dfelinto) closed this task as Archived.Mon, Nov 18, 9:41 PM

@Maciej Jutrzenka (Kramon) the original report indeed has no bug. Unlke 2.79 we dont have an object linked across scenes. The object is always linked to collections. If you believe you have a bug with a different situation and file, please report it separately. Closing this now based on the original report, thanks everyone for the investigations and back and forth.

The fact that the outliner Make Single User is not implemented yet is a separated issue and should be reported/tackled separately (although technically a feature request you can't make single user for collections, so I would consider a bug if reported).

@Maciej Jutrzenka (Kramon) the original report indeed has no bug. Unlke 2.79 we dont have an object linked across scenes. The object is always linked to collections. If you believe you have a bug with a different situation and file, please report it separately. Closing this now based on the original report, thanks everyone for the investigations and back and forth.
The fact that the outliner Make Single User is not implemented yet is a separated issue and should be reported/tackled separately (although technically a feature request you can't make single user for collections, so I would consider a bug if reported).

so if i have 2 diffrent collections and they have same object.. and i press make single user.. and it dosn't work.. i should report this?

@Maciej Jutrzenka (Kramon) the original report indeed has no bug. Unlke 2.79 we dont have an object linked across scenes. The object is always linked to collections. If you believe you have a bug with a different situation and file, please report it separately. Closing this now based on the original report, thanks everyone for the investigations and back and forth.
The fact that the outliner Make Single User is not implemented yet is a separated issue and should be reported/tackled separately (although technically a feature request you can't make single user for collections, so I would consider a bug if reported).

ah ok, so this functionality was still there in 2.8 (as shown in the video above) but has now been removed in 2.81?

@Maciej Jutrzenka (Kramon) the original report indeed has no bug. Unlke 2.79 we dont have an object linked across scenes. The object is always linked to collections. If you believe you have a bug with a different situation and file, please report it separately. Closing this now based on the original report, thanks everyone for the investigations and back and forth.
The fact that the outliner Make Single User is not implemented yet is a separated issue and should be reported/tackled separately (although technically a feature request you can't make single user for collections, so I would consider a bug if reported).

so if i have 2 diffrent collections and they have same object.. and i press make single user.. and it dosn't work.. i should report this?

The make single user options are also available in the object menu, it's just that they no longer work across scenes in 2.81 like they did in 2.79b and 2.80. Looks like the functionality has been removed.

@michael campbell (3di) No idea, I have not looked at the videos. I'm replying based on the original report.
@Maciej Jutrzenka (Kramon) if you can "press it" in a place where both objects can be distinguished from each other (e.g., in the outliner, not the viewport), then yes it is a bug that could be reported.

This comment was removed by michael campbell (3di).