Page MenuHome

Blenderkit: asset bar doesnt open
Open, Needs Triage by DeveloperPublic

Description

System Information
Operating system: Windows 10
Graphics card: AMD FirePro M4000

This is a work laptop

Blender Version
Broken: 2.80
Worked: never, installed for first time 9/16

Short description of error
Asset bar doesn't open search results are 0

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).

  • select blenderkit from tab on the right
  • select a category (any category they all act the same)
  • search runs (animals (2) so I should get at lest two things to show)
  • returns zero results, asset bar doesn't even open and attached image is what shows up on the right

Details

Type
Bug

Event Timeline

Demeter Dzadik (Mets) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.EditedTue, Oct 29, 9:24 PM

Could you clarify what addon this relates to?

Edit: I see, Blenderkit Asset Library. But I think you forgot to attach the screenshot you mentioned?

Demeter Dzadik (Mets) raised the priority of this task from Needs Information from User to Needs Triage by Developer.EditedWed, Oct 30, 2:38 PM

Trying to search for addon authors names on phabricator, CC @Vilem Duha (pildanovak) Can you take a look at this?

not sure why it didn't attach before. it seems the error cuts off at the end as it just says "(caused by" if there's a way to pull the whole error message let me know.
Even though this addon comes with blender when you install it may be this is something that I need to talk to the Blenderkit guys over? When I clicked "report a bug" in the preferences it sent me here.

Philipp Oeser (lichtwerk) renamed this task from asset bar doesnt open to Blenderkit: asset bar doesnt open.Wed, Oct 30, 3:51 PM

This is correctly reported here, and thanks for the report.
However, it seems like a possible firewall issue, or something else with the connection. BlenderKit uses the requests library, which simply uses default system settings to access web through https protocol. So basically the same as any web browser.
If you want to get the whole report, use window > Toggle system console, and there a longer output can be copy-pasted from.