Page MenuHome

2.81 Outliner: inconsistent selection and context menu
Closed, ResolvedPublicBUG

Description

Blender Version
Broken: 2.81, 2.82

In outliner, "Select" and "Select Objects" menu items select objects in 3D viewport, but not in the outliner. This makes these options unusable for selecting (disjoint) groups of objects.
Example:

  1. In the default scene, make a new collection and move one of the objects into it, let's say the Camera.
  2. In the Outliner, right click "Collection" and choose "Select Objects". Cube and light become selected, but there's no outliner selection background on them.
  3. In the Outliner, Ctrl-click the Camera.

Expected behavior: all three objects selected, Camera active.
Current behavior: Cube and Light are deselected, Camera is selected and active.

Furthermore, while an object is active in the outliner, right-clicking anything else in the Outliner brings up the Object context menu. So, for example, on cannot right-click a collection and see the "Select Objects" option.

Event Timeline

Germano Cavalcante (mano-wii) changed the task status from Unknown Status to Unknown Status.Nov 5 2019, 2:14 PM

This seems like it belongs in the paper cut thread and not the bug tracker:
https://devtalk.blender.org/c/user-feedback/paper-cuts

For suggestions on how to improve the UI, please use other channels:
https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests

What in the... what?!? Paper cuts? For this, really?!

You know what... whatever. If that's not a bug, then I don't know what is anymore. Until there's an actual documentation for the new outliner, I'll just consider every single inconsistency a feature. Outliner that selects but not selects, feature, got it.

Germano Cavalcante (mano-wii) changed the task status from Unknown Status to Unknown Status.Nov 5 2019, 6:54 PM

@Nathan Craddock (Zachman), would you mind confirming if this is a bug?

Philipp Oeser (lichtwerk) lowered the priority of this task from 90 to 50.

@Nathan Craddock (Zachman) : please also check:
T71404: 2.81 Outliner: selection not synced when editing armature
T71061: outliner doesn't move objects after "select hierarchy"

I could add here that objects are not activated/selected [the outliner selection I mean] after objects have been made real [Make Instances Real], do you want me to add a separate report for this?

Personally, I'd agree that this is a bug. However, I'll leave it to @Nathan Craddock (Zachman) to decide whether this report should be a Bug or Known-Issue.

Philipp Oeser (lichtwerk) changed the subtype of this task from "Report" to "Bug".

I dare calling this a bug.

Nathan Craddock (Zachman) closed this task as Resolved.May 2 2020, 3:42 AM
Nathan Craddock (Zachman) claimed this task.

This was resolved by rB5d14463e1aee which properly syncs object selection after Collection "Select Objects"