Page MenuHome

Hair missing after loading file
Closed, InvalidPublic

Description

System Information
Operating system: Linux mint 19.2 (Linux-5.0.0-32), Windows 10 (all fully updated)
Graphics card: Nvidia GeForce GTX 960M (driver 390.116)
Other: Intel i7-6700HQ, 16GB ram

Blender Version
Broken:
2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: rBf6cb5f54494e on Linux
2.81 (sub 16), branch: master, commit date: 2019-11-06 20:48, hash: rB85637311c28f on Linux
2.82-af33dbd71450 on Windows

Worked: -

Short description of error

When I open attached .blend file, I see two spheres. Bigger sphere should be covered in hair, but it's not. File should contain baked hair (see file size). Right after baking hair, I could see hair in viewport (both in *solid* and *rendered* viewport modes, using Eevee), but after pressing F12, I could only see bare spheres in render. When I used Cycles to render, hair showed up properly. After reloading file, hair does not show up anywhere. Even cycles render doesn't show hair, even though building BVH is unusually slow.

While working on that file, hair disappeared multiple times from viewport, but I couldn't find any pattern. After changing number of hairs, it reappeared, but I can't do that after long bake. I'm trying to create simple steps to reproduce problem without attaching .blend file, but I can't do it. (I haven't tried to bake it again because it takes some time.)

I have noticed interesting behavior after enabling Disk Cache (see optional steps to reproduce below). Maybe those additional 2GB of ram usage of hair cache can cause some problems, but I have enough ram available.

Exact steps for others to reproduce the error

  • Open attached ".blend" file.
  • See that hair is missing.

Optional:

  • Check Disk Cache in Particles context of bigger sphere (under Cache tab).
  • Save file.
  • File/Revert
  • Hair is now visible and it can be rendered.
  • Uncheck Disk Cache.
  • Save file.
  • File/Revert
  • Hair is missing again.

Edit: Rendering first frame works, but that nice baked physics is missing. (I could see collisions with other ball and nice swirling motion in viewport right after I baked physics yesterday. Now it does not work in viewport and render.) See video:

Event Timeline

Jacques Lucke (JacquesLucke) changed the task status from Needs Triage to Needs Information from User.Jan 9 2020, 4:36 PM

Sorry, I cannot do anything with that file. It is just too large to be useful for a bug report.

Please try to reproduce the issue in a smaller file to make it easier for us to reproduce and debug the issue.

Maybe the issue also has been solved by now?

Richard Antalik (ISS) closed this task as Invalid.Jan 16 2020, 11:59 AM
Richard Antalik (ISS) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to close the report.

Sorry for late reply, I didn't have much time last week. Back when this issue was created, I couldn't reproduce it with less hair and testing with same settings took too much time to iterate multiple times. Sorry I couldn't help more.