Page MenuHome

Rendered view not refreshing on GeForce RTX2080 after changing anything
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce RTX 2080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.12
64GB RAM, M2 SSD

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-08 22:59, hash: rB0a0d735acd6e
Worked: (optional)

Short description of error
[Hey guys, in rendered view (Cycles, CUDA, GPU Render) I found a problem. If I change anything in nodes so that the rendered view tries to refresh the rendered view "freezes" on the Initialisig state and not refreshing. Maybe this is an RTX only problem while I tried with my GTX1070i on my other PC and there is no refreshing problem in rendered view. I also tried the sam scene in Blender 2.8 with no refreshing issues.]

Exact steps for others to reproduce the error
[Please describe the exact steps needed to reproduce the issue] I'm experiencing this issue on RTX2080 with files with at least 100.000 faces, with HDRis and textures.
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from 90 to 30.Nov 13 2019, 12:08 PM
  • Does this happen for the default cube with Factory Settings as well?
  • For completeness sake: could you share a file where this happens?

Hi there,

no with the default cube is all good, as I said I'm experiencing this problem only in bigger projects, like this

Best regards,

Imre

Philipp Oeser (lichtwerk) raised the priority of this task from 30 to 90.Nov 15 2019, 3:07 PM
Philipp Oeser (lichtwerk) lowered the priority of this task from 90 to 30.Nov 15 2019, 3:29 PM

In this file, I cannot reproduce freezes (but I dont have RTX).

System Information
Operating system: Linux-5.3.7-200.fc30.x86_64-x86_64-with-fedora-30-Thirty 64 Bits
Graphics card: GeForce GTX 970M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21

what I do get though is [might be unrelated though]

GPUShader: compile error:
0(11537) : error C0000: syntax error, unexpected ',', expecting ')' at token ","

GPUShader: compile error:
0(11451) : error C0000: syntax error, unexpected ',', expecting ')' at token ","

Your screenshot implies it is stuck during the Updating Images phase.

  • is it always stuck in this phase? (if so, could you check if there is a particular image causing this? -- removing one by one?)

No, it is not only by updating images. Sometimes just on "Initializing". I tested it also on GTX cards and this problem happens ONLY on RTX.

Philipp Oeser (lichtwerk) raised the priority of this task from 30 to 80.Nov 15 2019, 4:03 PM

I have tested with an RTX2080TI in Windows 10 and after render, I opened compositor and added a viewer and bright/contrast node and the image backdrop is update very fast when changing the parameters of bright. No lag in backdrop. But, if you open a secondary window with render result, the image in this second window (or in the same window in a new area) does not change. I have tested other files and the screens are updated, but in this file doesn't.

Note: I tested with 25% of the size.

Tested the same file on RTX2080 with the Blender 2.8 without any issuses. The question is: which change causes this error in the 2.81 version...

I have the same issue in 2.80

Is this still an issue with latest build and drivers? https://builder.blender.org/download/

This could have been confirmed, but I don't have required GPU, so I can't check now.

With last version at 21/03/2020 I cannot reproduce the bug on Windows using RTX2080TI.

Richard Antalik (ISS) closed this task as Resolved.Mon, Mar 23, 2:10 AM
Richard Antalik (ISS) claimed this task.

Thanks, will close this then.