Page MenuHome

With Playback 'All 3D viewport' disabled, playback still happens due to Eevee temporal AA [Material, Rendered view]
Open, Confirmed, MediumPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 436.48

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-08 22:59, hash: rB0a0d735acd6e

Short description of error
Playback all 3D viewport disabled doesn't work with Material and Render preview (Eevee or Cycles)

Exact steps for others to reproduce the error

  1. open
  2. play animation with SPACE (mouse over lower viewport)
  3. Two upper viewport are animated, but Playback > All 3D viewport is disabled

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Confirmed, Medium.Thu, Nov 14, 5:16 PM
Philipp Oeser (lichtwerk) updated the task description. (Show Details)

Hmrf, thats because of temporal AA (causing a refresh that would normally be skipped in screen_animation_step by checking match_region_with_redraws)
But in EEVEE_temporal_sampling_draw you'll get an DRW_viewport_request_redraw -- and thats why it looks like its animating there...

That being said, if you set Eeve viewport samples to 1, it works [not saying this is a solution to the problem...]

Eh, @Jeroen Bakker (jbakker), @Clément Foucault (fclem): not sure there is an easy way around this?

Philipp Oeser (lichtwerk) renamed this task from Playback all 3D viewport disabled to With Playback 'All 3D viewport' disabled, playback still happens due to Eevee temporal AA [Material, Rendered view].Thu, Nov 14, 5:48 PM

I'm removing the Animation tag as it doesn't seem to be related to the animation system.