Page MenuHome

Nodes changed after import in blender 2.81 (due to versioning code of blend mode refactor)
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10
Graphics card: GeForce RTX 2070

Blender Version
Blender v2.80 and Blender v2.81 Beta Date: 2019-11-13 16:25 Hash: 9bd0d8b5505a
Worked: (optional)

Short description of error
The scene was created with blender 2.8. After opening in Blender 2.81, the rendering is not same :

Blender 2.80

Blender 2.81

Indeed, Blender added new nodes in the material. It's strange, for this reason I preferred to report it.

Blender 2.80

Blender 2.81

Exact steps for others to reproduce the error
Open this blend file with Blender 2.8 and after in Blender 2.81:

Best regards
Luc

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from 90 to 50.Nov 15 2019, 4:56 PM

Thats due to the versioning code of rB13d469e6f0c5.

@Clément Foucault (fclem): for cycles, this is not so nice, but it seems this material has seen some tweaking in Eevee as well [otherwise the Material->blend_method would not be set, right?]
Dont have a quick idea to solve nicely...

CC @Brecht Van Lommel (brecht) here as well

Philipp Oeser (lichtwerk) renamed this task from Nodes changed after import in blender 2.81 to Nodes changed after import in blender 2.81 (due to versioning code of blend mode refactor).Nov 15 2019, 4:57 PM

One idea would be to check what render engine is set in the scene but then you run into issue where someone will have setup his material to have an EEVEE (workbench) preview but a Cycles render (active renderer).

Doing it one way or another will never satisfy all the cases so that's why we went for a simpler approach where we convert all outputs that are used by EEVEE.

How about adding an extra output node for eevee, to which the "corrected" node setup is connected;
and leaving the unchanged setup connected to the - now separate - cycles output node?

Jeroen Bakker (jbakker) closed this task as Invalid.Mon, Jan 13, 4:33 PM
Jeroen Bakker (jbakker) claimed this task.

Will mark this as a known issue as it works as intended.