Page MenuHome

Mesh showing what's behind even without wireframe activated
Closed, InvalidPublic

Description

System Information
Operating system: Darwin-19.0.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) UHD Graphics 630 Intel Inc. 4.1 INTEL-14.2.16

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-12 13:28, hash: rB125257758007
Worked: (optional)

Short description of error
I can see through the mesh in edit mode when I move further from the object. When I zoom in it starts to draw properly.

Exact steps for others to reproduce the error
Add a Plane. Add a solidify modifier. Apply. Add a subsurface modifier, set it by 6 and apply.
Zoom in and out of the mesh and you can see how the drawing of the mesh changes.

Event Timeline

The same here both on 2.81 rB125257758007 and 2.81 (sub 16), branch: master, commit date: 2019-11-15 16:32, hash: rBeba4a4bd73ba

It appears also in a default file after I apply solidify modifier and after setting a greater distance from the object, both in the viewport and through the camera.
It shows up from a bit smaller distance after adding solidify with subdivision modifier.

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

You have "Clip End" set to a ridiculous number (20km):


Set it to something more reasonable, like 10m.

Philipp Oeser (lichtwerk) changed the task status from Unknown Status to Invalid.Nov 19 2019, 9:44 AM
Philipp Oeser (lichtwerk) claimed this task.

I can only second what @Marcin Twarowski (Tvaroog) said [thx for continuous help triaging here btw!]

Lowering the range of the clipping planes is the solution here, not a bug afaict.