Page MenuHome

In weight painting mode switching bones make weights invisible
Closed, ResolvedPublic

Description

System Information
Operating system: Mac OS Catalina 10.15.1
Graphics card: Intel HD 6000

Blender Version
Broken: 2.81 release
Worked: 2.80, 2.82 alpha (1 Dec 2019)

Short description of error
In weight painting mode switching bones make weights invisible. So it's not productive to always switch between modes just to see vertex weights again.

Exact steps for others to reproduce the error

  1. Open Rig3.blend
  2. In object mode select "Rig"(armature)
  3. Then select object "Dayly"
  4. Switch to "weight painting" mode
  5. With "Ctrl + LMB" select other bone
  6. Weights are now invisible...

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Tue, Nov 19, 3:43 PM

Cannot reproduce here

System Information
Operating system: Linux-5.3.7-200.fc30.x86_64-x86_64-with-fedora-30-Thirty 64 Bits
Graphics card: GeForce GTX 970M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 435.21
version: 2.81 (sub 16), branch: master, commit date: 2019-11-18 12:53, hash: rB115a5bf65a6b

Only thing I can think of is
https://docs.blender.org/manual/en/dev/troubleshooting/gpu/index.html
Could you check if any of that applies/helps?

Volodymyr (linosia) added a comment.EditedTue, Nov 19, 4:09 PM

On macOS graphics drivers are built into the operating system and the only way to get newer drivers is to upgrade macOS as a whole to the latest version.

"Your Mac is up to date -- Mac OS Catalina 10.15.1
Sorry, that's not the case...

Maybe you can add(assign) someone, who use Mac OS Catalina to test?
Would be much grateful :)

Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.Tue, Nov 19, 4:23 PM

@William Reynish (billreynish) : Have you seen this before / can you reproduce this?

Also, may be connected with bug T71500

Works well (no bug) on 2.80 release. So it's not my drivers or OS :)

I can confirm this exact issue.

Mac OS Catalina 10.15.1
Graphics cards:
Radeon Pro 555X 4 GB
Intel UHD Graphics 630 1536 MB

Blender Version: 2.81

3 users on same OS (Mac OS Catalina 10.15) have confirmed that issue.

Can any of the developers reproduce this problem?

Volodymyr (linosia) updated the task description. (Show Details)

Tried new 2.82 alpha 1 December.
Bug IS GONE.
Big thanks!

Anyone please -- go to https://builder.blender.org/download/
Install latest 2.82 alpha and test it.

After one more testing we can close this thread :)

I've just checked v 2.82 on a mac, and yeah, bug is gone :) It works like a charm, great job!

Robert Guetzkow (rjg) closed this task as Resolved.Sun, Dec 1, 7:23 PM
Robert Guetzkow (rjg) claimed this task.

Closing this bug report since the issue seems to be resolved.

If the issue occurs again and wasn't properly fixed, please re-open the ticket.