Page MenuHome

Speeding up a video in Video Editor is very confusing (usability)
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.20

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: rB26bd5ebd42e3
Worked: (optional)

Short description of error
Usability issue

Exact steps for others to reproduce the error

Open video Editor
Import a video

Expected: (something along these lines)

  • right click > "Speed Control" or Add Strip Modifier > Speed control
  • select Speed 2x
  • See the strip length being reduced by 2x, visually representing the reduced time

Observed:
I have to add an Effect Strip, which adds a new strip in the editor (despite the effect being applied to the video strip).
Once sped up, the video strip is still the same length, making is very hard to edit precisely.

Event Timeline

Some work has been done to clear up the Speed Strip UI: https://developer.blender.org/D6110 It has been accepted, so it's just waiting for someone with commit rights to actually commit it.

Sure it is odd to both have effect strips and modifiers, it should really be one or the other, but currently there is no VSE coder-manpower to deal with stuff like this.

Richard Antalik (ISS) lowered the priority of this task from 90 to 50.Dec 1 2019, 11:48 PM
Jeroen Bakker (jbakker) closed this task as Invalid.Tue, Jan 7, 11:28 AM
Jeroen Bakker (jbakker) claimed this task.

I close this report as it works as intended and not considered a bug. Work is on its way, no need to keep this issue open