Page MenuHome

Error on importing .svg to Blender 2,81
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Graphics card: AMD Radeon R9 200 / HD 7900

Blender Version
Broken: version: 2.81 (sub 16), branch: master
Worked: (optional) 2.80 (sub 75), branch: master

Short description of error
Cannot import .svg files into blender after updating to 2.81

Exact steps for others to reproduce the error
Traceback (most recent call last):

File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\__init__.py", line 59, in execute
  return import_svg.load(self, context, filepath=self.filepath)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1882, in load
  load_svg(context, filepath, do_colormanage)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1872, in load_svg
  loader.parse()
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1085, in parse
  ob = parseAbstractNode(node, self._context)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1856, in parseAbstractNode
  ob.parse()
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1085, in parse
  ob = parseAbstractNode(node, self._context)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1856, in parseAbstractNode
  ob.parse()
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1085, in parse
  ob = parseAbstractNode(node, self._context)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1856, in parseAbstractNode
  ob.parse()
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1085, in parse
  ob = parseAbstractNode(node, self._context)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1856, in parseAbstractNode
  ob.parse()
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1085, in parse
  ob = parseAbstractNode(node, self._context)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1856, in parseAbstractNode
  ob.parse()
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 1134, in parse
  pathParser = SVGPathParser(d, self._styles['useFill'])
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 508, in __init__
  self._data = SVGPathData(d)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\import_svg.py", line 420, in __init__
  token, last_char = read_float(d, i)
File "C:\Program Files\Blender Foundation\Blender 2.81\2.81\scripts\addons\io_curve_svg\svg_util.py", line 88, in read_float
  raise Exception('Invalid float value near ' + text[start_index:start_index + 10])

Exception: Invalid float value near -.41,11,11

location: <unknown location>:-1

Details

Type
Bug

Event Timeline

Stephen Swaney (stiv) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Sun, Nov 24, 12:16 PM

Can you show us the section of the .svg file that fails to parse?

Looks like a manifestation of T71774 SVG Import Error recently fixed by @Sergey Sharybin (sergey). Compare backtrace, above, with that in the screenshot in SVG Import Error. Note that the screenshot reads from the bottom up with respect to the backtrace here.

Try testing with daily 2.82 alpha build. Does the problem go away?

Jean First (robbott) closed this task as Archived.Tue, Dec 3, 9:32 AM
Jean First (robbott) claimed this task.

please test with latest blender from https://builder.blender.org/download/ and if you still have this error, reopen this task.