Page MenuHome

Blender Game Engine missing in 2.80+
Closed, ArchivedPublic

Description

I was mostly using Blender for simulations and interactive visualizations controlled by Python. Now 2.80 REMOVED the Blender Game Engine with no replacement!!!!

Really not cool to remove something that was there for decades with no replacement! I have checked the external game engines but this is not the same - I need to export/import and write in some funny languages which is no use for me - while I had everything at hand in Blender :-(

Belnder became just a 3D modelling tool.. which still is no use for engineering modelling :-(

Is there any way so I can perform a live real-time visualizations that are Python controlled in new Blender 2.80+ ? I don't really need physics (but the collisions would be nice to have).

Any hints welcome.. or I need to stick to 2.79 and have no real purpose to use 2.80+ :-(

Details

Type
Bug

Event Timeline

CeDeROM (cederom) updated the task description. (Show Details)
Maciej Jutrzenka (Kramon) closed this task as Resolved.Tue, Nov 26, 2:47 PM
Maciej Jutrzenka (Kramon) claimed this task.

Thanks for the report, but please use other channels for user feedback and feature requests: https://wiki.blender.org/wiki/Communication/Contact#User_Feedback_and_Requests
For more information on why this isn't considered a bug, visit: https://wiki.blender.org/wiki/Reference/Not_a_bug

Philipp Oeser (lichtwerk) changed the task status from Resolved to Archived.Tue, Nov 26, 2:52 PM

Well, this was removed on purpose, so it is no bug...

An Interactive Mode is planned, see T54389: Blender Interactive Mode Outline, but with no significant progress so far.

Recommendation can be found here
https://wiki.blender.org/wiki/Reference/Release_Notes/2.80/Removed_Features

There is also a fork called UPBGE [which has the gameengine in 2.8] https://github.com/UPBGE/blender/tree/upbge0.3
And of course, you could continue using 2.79...

Anyhow, will have to close this as not-a-bug....

"IT'S NOT A BUG IT'S A FEATURE"^TM yeah right. Really not cool to simply remove something that was core functionality and philosophy of Blender from its first steps providing absolutely no working alternative. It's just not there anymore, so no problem, but we have new buttons, and we look like the rest of the software, erghh :-(

I was really waiting for 2.80 even though there was no BGE in previews, but I would never even consider, that you would simply trash its biggest core feature and stay okay with that.

In the good old days you would have to provide a better solution first in order to remove a solution completely.

I would have to complete my project with 2.79, but I have no reason at all to use Blender anymore.

You have removed its core functionality. Not even moved it into an AddOn, nor anything else. It's just not there.

I just want you to know that.

Blender game engine was dead. the moment sony decided that it will not run on PS1.

While we don't ship it anymore, the people at https://upbge.org/ are keeping it alive in a fork

Not true. Maybe for Sony. Blender was the only truly Open-Source utility with integrated 3d modelling, python interpreter, text editor, and VR simulation editor that could produce external standalone binaries. BGE was sucking a bit, but still you could create a very nice VR environment in a seconds that could interact with real world over Python. You could run it on a low power embedded system and that was all-in-one-you-need.

This approach was the biggest asset of Blender. You have destroyed it. Now Blender is just another fancy 3D modelling+renderig utility, nothing more.

There was much more to Blender than games. It could be used as engineering tool for connecting real world and VR in R&D projects.

Now when I have to use external engine there is absolutely no reason to use Blender anymore.

Thank you for pointing to UBGE. I am building it on my FreeBSD box right now and there are problems around 50% of compilation progress. This may be the quick-fix. But I just consider taking out my MacBookPro and simply using 2.79 to get the job done, find something else I could stick to, and forget Blender (which I am biggest fan since around 2000 and I remember taking part in crowdfunding in order to release the sources around 2003).

If you do not intend to bring back the BGE (which I know has its weak spots) please at least bring any sort of alternative that I could use to produce interactive application with Python connecting to a real world sensors/acurators in a way BGE worked.

Really guys, with no BGE or anything like this in upcoming weeks, I have no reason to use Blender.

Also no reason to proudly wear Blender T-Shirt anymore.

https://github.com/UPBGE/blender/tree/upbge0.3

bge is working in a fork -
https://www.youtube.com/watch?v=yOTTQAFZXww&feature=youtu.be
a build is available in this video description in LordLoki's Mega drive.

it's still pre alpha but is very close to usable
https://www.youtube.com/watch?v=YU1M6xVPAt8

one caveat is the armature modified is slower in 2.8 and not yet working in 'master' for spawned object - however I just use bone parent rigs
(objects parented to armature bones) removing the cost of deformation, and allowing spawned instances.

Loki is working on GPU armature skinning, and youle has fixes for spawned armature modifier but if staging in a local branch of his own.

If Blender 2.79 works for you, use it. It isn't going away.

@Stephen Swaney (stiv) youle and loki have restored upbge to blender 2.8 fork - upbge 0.3
it's like you totally skipped that

it's already getting good. have you tried it?