Page MenuHome

Sidebar does not update pinned panels in other tabs
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Linux 5.3.13 (Manjaro with last updates)
Graphics card: None (internal Intel HD 4600 (Haswell))

Blender Version
Broken: 2.81, 2.82 (build date: 2019-11-28, hash: 4659fa547166)
Worked: ???

Short description of error

Sidebar do not update pinned blocks on selecting tools on toolbar.

Exact steps for others to reproduce the error

  1. Open a new scene of Blender
  2. In object or edit mode press N for activate sidebar if she don't displayed
  3. Click tab Tool on sidebar and checked option Pin by right mouse button on block Active tool
  4. Come back to tab Item on sidebar and try selecting tools on toolbar. Active tool on sidebar do not updated (refreshed)

P.S. The block is updated only if you wheel the mouse on it after selecting tool on sidebar

Event Timeline

Vovchik (vademenev) updated the task description. (Show Details)
Philipp Oeser (lichtwerk) lowered the priority of this task from 90 to Low.Nov 28 2019, 9:44 AM

Can confirm.

Philipp Oeser (lichtwerk) renamed this task from Sidebar do not update pinned blocks to Sidebar does not update pinned panels in other tabs.Nov 28 2019, 9:44 AM
Pasang Bomjan (irex124) closed this task as Resolved.Feb 1 2020, 1:35 PM
Pasang Bomjan (irex124) claimed this task.

This seems to have been fixed in the latest master 2.83. So I'm closing it.

Please reopen issue again. Do not working on change tool. Active tool changes when only click on object or hover mouse on block of active tool. Tool change happens in Tool Settings Bar but do not in Active Tool. See video:

Evan Wilson (EAW) reopened this task as Confirmed.Feb 2 2020, 6:53 AM
Evan Wilson (EAW) removed a project: Tracker Curfew.

Confirmed using rBf051d47cdbce

Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Bug".Feb 17 2020, 4:00 PM
David Friedli (hlorus) closed this task as Resolved.Sep 28 2020, 8:05 AM
David Friedli (hlorus) claimed this task.

Resolved since b1bdfb6e32b9