Page MenuHome

Crash on startup (TBB related)
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: Catalina 10.15.1
Graphics card: RX 560

Blender Version
2.81

Crashing on launch. Here is a crash log, https://pastebin.com/WvU69fkn

Details

Type
Bug

Event Timeline

Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Fri, Nov 29, 11:19 AM

Please attach the corresponding .blend file...

Please attach the corresponding .blend file...

The crash happens opening the application alone. There is no .blend file being loaded.

Understand we can't do much unless we can reproduce this issue.

According to crash log blender crashed on:

tbb::interface7::internal::task_arena_base::internal_max_concurrency(tbb::interface7::task_arena const*) + 50

tbb was only added recently to blender I think in quad remesher.

Some other things to try.

  1. Try a recent nightly build from here.
  2. Try starting blender with --factory-startup from the console.
  3. You don't say in your report if 2.80 crashes or not?
Philipp Oeser (lichtwerk) renamed this task from Crash on load to Crash on startup (TBB related).Thu, Dec 5, 10:03 AM
Philipp Oeser (lichtwerk) raised the priority of this task from Needs Information from User to Waiting for Developer to Reproduce.

I can confirm that the 2.82 alpha also crashes in relation to TBB. 2.80 runs as intended.

Works fine on my MBP, both 2.81 and latest master builds from builder.blender.org.

@Sebastián Barschkis (sebbas) or @William Reynish (billreynish) should be able to test relatively easily as well.

Both the latest master and 2.81 do not give me a startup crash either on macOS.