Page MenuHome

Restriction Toggle Settings Are Not Unique To View Layers and Are Lost When Switching
Closed, ArchivedPublic

Description

System Information
Operating system: Linux-5.3.13-arch1-1-x86_64-with-arch 64 Bits
Graphics card: GeForce GTX 660M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 440.36

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: rB26bd5ebd42e3

Short description of error
If you set Restriction Toggles in View Layer 1, switch from View Layer 1 to View Layer 2, make changes to Restriction Toggles in View Layer 2, and switch back to View Layer 1, your settings for View Layer 1 are now lost.

Exact steps for others to reproduce the error
Create a new Collection beside your initial one.
Show all Restriction Toggles.
Take note of what Restriction Toggles are enabled
Create a new View Layer.
Set all Restriction Toggles to off for the new collection.
Switch Back to the first View Layer.
Restriction Toggles are not the same as when you left.

Details

Type
Bug

Event Timeline

I can imagine that this would be a useful feature, but this is not a bug. The visibility state is tied to the object or collection, not the view layer.

Robert Guetzkow (rjg) closed this task as Archived.EditedSun, Dec 1, 2:09 PM
Robert Guetzkow (rjg) claimed this task.

While this change could be a very useful feature in the future, it would also impact several parts of Blender's code, including the Python API. Therefore this is something that needs to be discussed, properly designed and approved by module owners.

I would suggest posting about this feature on right-click select to get feedback from other users and discussing it with the developers on DevTalk, if you want to be involved in the (potential) development.

I'll be closing this ticket because it's a feature request.

Fine, while I still regard this as a bug, I can see how it would be better to be designed with and approved by module owners. But even though the current behavior is expected by developers, it is not clear to the user what to expect. Could the tooltips at least be made more consistent so that the user has a better idea what is View Layer specific and what is global across all View Layers?

@Ryan Inch (Imaginer) Sure I don't see why not. You can submit a diff if you already have suggestions how a better description should look like. Although I think the tooltips are currently quite clear that they are applied globally. For example:

Disable in Viewports.
Globally disable in viewports.
*Shift to set children

Disable in Renders.
Globally disable in renders.
*Shift to set children

@Robert Guetzkow (rjg) Those ones are alright, but a couple of the other ones could use improvement. For example:

Hide in Viewport.
Temporarily Hide in Viewport.

(This is View Layer specific)

Disable Selection.
Disable selection in viewport.

(This is Collection specific)

Both of these are worded very similarly, but one affects the View Layer and the other the Collection.

And the one for show_restrict_column_select is just:

Selectable.
Selectable.

I'll submit a diff with hopefully, clearer wording.