Page MenuHome

[START_CRASH] Blender 2.81 Intel
Open, Waiting for Developer to ReproducePublic

Description

System Information
Operating system: Windows 10 Pro (1909)
Graphics card: Intel(R) HD Graphics 630, version 4.5.0 - Build 26.20.100.6951

Blender Version
Broken: 2.81, downloaded 2019-12-01 from blender.org
Worked: 2.80 worked.

Short description of error
Blender crashes on start:

C:\Program Files\Blender Foundation\Blender 2.81>blender.exe
GPUTexture: create : TEXTURE_1D, RGBA8, w : 1, h : 0, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: texture alloc failed. Likely not enough Video Memory.
Current texture memory usage : 0.00 MiB.
GPUTexture: create : TEXTURE_2D, RGBA8, w : 1, h : 1, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: texture alloc failed. Likely not enough Video Memory.
Current texture memory usage : 0.00 MiB.
GPUTexture: create : TEXTURE_3D, RGBA8, w : 1, h : 1, d : 1, comp : 4, size : 0.00 MiB
GPUTexture: texture alloc failed. Likely not enough Video Memory.
Current texture memory usage : 0.00 MiB.
found bundled python: C:\Program Files\Blender Foundation\Blender 2.81\2.81\python
GPUTexture: create : TEXTURE_2D, RGBA8, w : 3435, h : 26, d : 0, comp : 4, size : 0.34 MiB
GPUTexture: texture alloc failed. Likely not enough Video Memory.
Current texture memory usage : 0.34 MiB.
GPUTexture: create : TEXTURE_2D, R8, w : 16384, h : 128, d : 0, comp : 1, size : 2.00 MiB

This appears to be similar to T69594.

Exact steps for others to reproduce the error

  1. Download 2.81.
  2. Launch 'blender.exe'

Details

Type
Bug

Event Timeline

Robert Guetzkow (rjg) closed this task as Archived.EditedSun, Dec 1, 11:07 PM
Robert Guetzkow (rjg) claimed this task.

Blender is using the integrated graphics of your CPU instead of a dedicated GPU on your system. Try to configure it through the Nvidia control panel to use one of the dedicated GPUs. You should also update the driver for your integrated GPU since it should be capable of running Blender. The current drivers for the dedicated GPUs can be downloaded from the Nvidia website.

I will be closing this bug report, since the issue seems to be caused by a problem with the graphics drivers or GPU configuration. If the problem should not be fixed by the suggested steps, please re-open the bug report.

I want Blender to be using the integrated graphics.

What exactly do you want me to change because I've never had a need to touch any of my Nvidia settings.

Blender 2.80 worked just fine.

Blender 2.79 worked just fine.

What changed with 2.81?

Zbrush works just fine.

Silo works just fine.

Marvelous Designer works just fine.

The Nvidia GPUs are only used for rendering. I have no displays plugged into them.

And it's not a problem with the Intel GPU because my Surface Pro has an Intel GPU that loads Blender 2.81.

So something is seriously broken in 2.81 as evidenced by the fact you now have multiple reports of this issue.

Robert Guetzkow (rjg) reopened this task as Open.EditedMon, Dec 2, 12:35 AM

It's fine if you intentionally used the integrated graphics. Due to your powerful dedicated GPUs I assumed this might be unintentional. If it worked properly in Blender 2.8 it could be a bug indeed.

Please try to update your graphics drivers anyway so we can rule out any issue caused by them. Just because the problem doesn't occur with other software doesn't mean that the driver isn't at fault.

I'll re-open the issue.

Robert Guetzkow (rjg) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mon, Dec 2, 12:40 AM

@Robert Guetzkow (rjg) his GPU intel one.. is supported GPU and if he want's to run it on intel he absolutly can. And it should work.

@George Ellenburg (gellenburg) Hi! in deed the 2.81 introduced a few GPU problems as many reports are happening.. however a lot of them is simply because of the drivers are not up to date.. plz try updateing your drivers following this page: https://docs.blender.org/manual/en/dev/troubleshooting/gpu/index.html it is important to use drivers directly from manufacture of GPU intel/amd/nvidia and not from PC manufacture like dell etc.. as they often have old and bugged drivers.

Maciej Jutrzenka (Kramon) renamed this task from Blender 2.81 crash on start to Blender 2.81 crash on start INTEL GPU.Mon, Dec 2, 1:24 AM
Maciej Jutrzenka (Kramon) updated the task description. (Show Details)
Maciej Jutrzenka (Kramon) updated the task description. (Show Details)
Maciej Jutrzenka (Kramon) renamed this task from Blender 2.81 crash on start INTEL GPU to [START_CRASH] Blender 2.81 Intel.Mon, Dec 2, 1:53 AM

@Maciej Jutrzenka (Kramon)

Robert Guetzkow (rjg) his GPU intel one.. is supported GPU and if he want's to run it on intel he absolutly can. And it should work.

Which is exactly what I said:

[...] You should also update the driver for your integrated GPU since it should be capable of running Blender. [...]

It's fine if you intentionally used the integrated graphics. [...]

I've already linked the pages for the driver downloads (see first comment).

Please don't add unnecessary noise into the triaging process. Thank you.

@George Ellenburg (gellenburg) Please let us know if the driver updates improved the situation.

@Clément Foucault (fclem) If the driver update doesn't solve the issue, this might be something for you to look at.

@George Ellenburg (gellenburg) Hi! in deed the 2.81 introduced a few GPU problems as many reports are happening.. however a lot of them is simply because of the drivers are not up to date.. plz try updateing your drivers following this page: https://docs.blender.org/manual/en/dev/troubleshooting/gpu/index.html it is important to use drivers directly from manufacture of GPU intel/amd/nvidia and not from PC manufacture like dell etc.. as they often have old and bugged drivers.

Hi. Good morning. I did that yesterday after I received Robert's first reply. I downloaded the latest drivers from Dell (Microsoft said there were no updates). Installed. And rebooted.

Same behavior. Still crashes.

Thank you.

Here is the msinfo32 output for the display driver:

Name Intel(R) HD Graphics 630
PNP Device ID PCI\VEN_8086&DEV_5912&SUBSYS_07DB1028&REV_04\3&11583659&0&10
Adapter Type Intel(R) HD Graphics Family, Intel Corporation compatible
Adapter Description Intel(R) HD Graphics 630
Adapter RAM 1.00 GB (1,073,741,824 bytes)
Installed Drivers C:\WINDOWS\System32\DriverStore\FileRepository\ki132869.inf_amd64_052eb72d070df60f\igdumdim64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki132869.inf_amd64_052eb72d070df60f\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki132869.inf_amd64_052eb72d070df60f\igd10iumd64.dll,C:\WINDOWS\System32\DriverStore\FileRepository\ki132869.inf_amd64_052eb72d070df60f\igd12umd64.dll
Driver Version 26.20.100.6951
INF File oem3.inf (iKBLD_w10_DS section)
Color Planes Not Available
Color Table Entries 4294967296
Resolution 3840 x 1600 x 59 hertz
Bits/Pixel 32
Memory Address 0xDB000000-0xDBFFFFFF
Memory Address 0x90000000-0x9FFFFFFF
I/O Port 0x0000FEC0-0x0000FEFF
IRQ Channel IRQ 4294967275
Driver C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\KI132869.INF_AMD64_052EB72D070DF60F\IGDKMD64.SYS (26.20.100.6951, 19.10 MB (20,024,184 bytes), 7/15/2019 3:15 AM)

I will download the latest driver directly from Intel per your request this afternoon. I need to leave for work now.

https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630

Just an FYI it won't let me install the driver from Intel:

Maciej Jutrzenka (Kramon) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mon, Dec 2, 1:48 PM

The crash log looks incomplete.
That common EXCEPTION_ACCESS_VIOLATION information is missing at the end of it.
It's something like this:

(...)
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x0000000065538649
Module  : C:\Windows\system32\nvoglv64.DLL

Try to run blender_debug-gpu.cmd that is included in the download.
After Blender closes, the logs will be in a text file which can be attached here.

Also test the others like blender_debug_gpu_glitchworkaround.cmd and report here if any of them make a difference.

Robert Guetzkow (rjg) added a comment.EditedMon, Dec 2, 2:39 PM

@George Ellenburg (gellenburg) That's unfortunate, some vendors block the installation of drivers. You may be able to install the driver manually through the device manager as described in this How-to Geek tutorial (at your own risk).

Robert Guetzkow (rjg) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mon, Dec 2, 4:30 PM

Unable to manually update the driver. It will not apply. Was directed to use the Intel Driver Driver & Support Assistant. Here's the result of the scan:

And here's the full scan report:

Somebody had mentioned that the debug logs did not appear to be complete.

They were generated from running the debug .cmd file.

I'll run it again for you!

Oops. Pasted the wrong image. Here:

For kicks and grins I just tried to (download) & run Blender 2.81 portable (ZIP) and the Steam version.

Both crash on startup as well.

Maciej Jutrzenka (Kramon) raised the priority of this task from Needs Information from User to Needs Triage by Developer.Mon, Dec 2, 10:13 PM
Philipp Oeser (lichtwerk) lowered the priority of this task from Needs Triage by Developer to Waiting for Developer to Reproduce.Tue, Dec 3, 11:40 AM

@Jeroen Bakker (jbakker), @Clément Foucault (fclem): anything to check further here?

@George Ellenburg (gellenburg) Can you try the 2.82 beta?

I really think this is a driver issue. Texture creation seems to fail just after the first one.

The GL_OUT_OF_MEMORY is concerning but i'm pretty sure it's a false alert.

Why is that so? Why does it work in 2.80? did someone touch the GHOST layer? @Jeroen Bakker (jbakker) have you any idea?

The last change to the GhostWGL part was done in Mai 2019 so would already be present in 2.80.
Looking at the information of the log files. There is a log where it crashes inside the NVIDIA driver, but Blender thinks it is using the Intel GPU. that could be related to the soft switch etc.
My guess would be that a different OpenGL driver is selected between the OS vs Blender. The driver doesn't know the Intel GPU and fails on all calls. But this is a big guess, we need to find proof of this. Especially as 2.80 worked.

Best way forward is to find the commit that fails on this configuration, but that needs a developer (or technical user) to proceed. @George Ellenburg (gellenburg) are you up to such a task?

Sometimes these configurations have the ability in the bios to select which GPU is the primary GPU...

There are also other ways to run with only one gpu. Sometimes, you can just rightclick on the executable file and choose with gpu to use.

Something got changed in 2.81 compared to 2.80 that triggers low end GPU's like crazy. @Clément Foucault (fclem) maybe this is some what linked to that issiue that was on mac and that merged report about multiple materials?

Same problems here, Blender works great with 2.80 and 2.81 worked for a day then crashes at start up.
No driver updates from Nvidia and Intel will not let me update my graphic 630.

If it helps 2.81 worked great until I updated Bpainter for 2.81 and even that worked for a couple hours?

I'm not a programmer but have invested into 2.81 and would actually like it to work without me having to code?

I'm currently back using 2.80 and there is no issue.

Robert Guetzkow (rjg) added a comment.EditedTue, Dec 3, 5:17 PM

@Bryan F (BryanF) That's interesting, so 2.81 worked correctly at first for you. Can you start Blender 2.81 from the command line with the --factory-startup flag? It could be that the Bpainter update is a red herring though, since nothing in the error log of gellenburg suggests a crash caused by an add-on.

Could you please create a debug log of Blender 2.81 by running the blender_debug_gpu.cmd in its installation directory (by double clicking) and post the files here? Do you remember or can you check if there have been any Windows updates between the time 2.81 worked and then didn't?

@George Ellenburg (gellenburg) Have you been using Bpainter as well?

I've never used Bpainter.

I will download the 2.82 beta and give it a try.

Ok this is weird.

Just downloaded and ran:

Blender 2.82 Alpha
December 03, 15:36:19 - b81939716de8
Windows 64 bit
146.75MB

When I clicked on blender.exe it crashed.

When I ran the command blender_factory_startup.cmd it crashed.

And it generated logs but I didn't save them. Sorry.

So I realized you probably want me to run blender_debug_gpu.cmd so I did.

And now this:

And here are the generated logs:

So let me try running blender_factory_startup.cmd again.....

Yep. It crashed.

Here are those logs:

So let me try blender_debug_gpu.cmd again......

And it works!

And here are those (new) logs again too.

Jeroen Bakker (jbakker) claimed this task.EditedTue, Dec 3, 11:36 PM

Excellent. When running with the gpu scripts. All available workarounds for driver bugs are enabled. One of them needs to be enabled for your driver configuration.

The upcoming days we will enable them one by one to find out which one is the needed workaround.

Please hold back until we give a signal to test.

IIRC only blender_debug_gpu_glitchworkaround activates the workarounds. gpu_debug only enable the debug opengl extension which might trigger a specific driver path.

This comment was removed by Bryan F (BryanF).

I can't respond directly so I'll post this here. to @Robert Kirberich (robert) Guetzkow

@echo off
echo Starting blender with GPU debugging options, log files will be created
echo in your temp folder, windows explorer will open after you close blender
echo to help you find them.
echo.
echo If you report a bug on https://developer.blender.org you can attach these files
echo by dragging them into the text area of your bug report, please include both
echo blender_debug_output.txt and blender_system_info.txt in your report.
echo.
pause
mkdir "%temp%\blender\debug_logs" > NUL 2>&1
echo.
echo Starting blender and waiting for it to exit....
set PYTHONPATH=
blender --debug --debug-gpu --python-expr "import bpy; bpy.ops.wm.sysinfo(filepath=r'%temp%\blender\debug_logs\blender_system_info.txt')" > "%temp%\blender\debug_logs\blender_debug_output.txt" 2>&1 < %0
explorer "%temp%\blender\debug_logs"

In addition I got it to start up from the factory start up line but I'm not sure if I should operate the program regularly from this point???
It also doesn't have any addons attached (set up).
Nor has my windows 10 updated since I first downloaded 2.81

thanks

Robert Guetzkow (rjg) added a comment.EditedWed, Dec 4, 1:06 PM

@Bryan F (BryanF) There's been a misunderstanding, you should've double clicked on the blender_debug_gpu.cmd and uploaded the two files that are opened in the Windows Explorer once you close Blender (blender_debug_output.txt and blender_system_info.txt). Files can be uploaded by clicking on the cloud with an up-arrow icon. Since starting with factory settings allows you to run Blender properly it seems you don't have the same issue. In your case it may be caused by the problematic add-on which is disabled through --factory-startup . Uninstalling the problematic add-on should solve your issue.

@Clément Foucault (fclem) As a test I ran 2.81 blender_debug_gpu_glitchworkaround.cmd and here was the generated log (it crashed too):

blender-2.82-fda791ab1241-windows64:

blender.exe: CRASH

blender_debug_gpu.cmd:

blender_debug_gpu_glitchworkaround.cmd: no crash

blender_debug_log.cmd: CRASH

blender_factory_startup.cmd: CRASH

Hope this helps.

@Bryan F (BryanF) There's been a misunderstanding, you should've double clicked on the blender_debug_gpu.cmd and uploaded the two files that are opened in the Windows Explorer once you close Blender (blender_debug_output.txt and blender_system_info.txt). Files can be uploaded by clicking on the cloud with an up-arrow icon. Since starting with factory settings allows you to run Blender properly it seems you don't have the same issue. In your case it may be caused by the problematic add-on which is disabled through --factory-startup . Uninstalling the problematic add-on should solve your issue.

Switching to fully guarded memory allocator.
Blender 2.81 (sub 16)
Build: 2019-11-20 16:33:00 Windows Release
argv[0] = blender
argv[1] = --debug
argv[2] = --debug-gpu
argv[3] = --python-expr
argv[4] = import bpy; bpy.ops.wm.sysinfo(filepath=r'C:\Users\bry\AppData\Local\Temp\blender\debug_logs\blender_system_info.txt')
Read prefs: C:\Users\bry\AppData\Roaming\Blender Foundation\Blender\2.81\config\userpref.blend
read file C:\Users\bry\AppData\Roaming\Blender Foundation\Blender\2.81\config\startup.blend

Version 281 sub 16 date 2019-11-20 14:27 hash 26bd5ebd42e3

GPUTexture: create : TEXTURE_CUBE_MAP, RGBA16F, w : 2, h : 2, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: create : TEXTURE_1D, RGBA8, w : 1, h : 0, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: create : TEXTURE_2D, RGBA8, w : 1, h : 1, d : 0, comp : 4, size : 0.00 MiB
GPUTexture: create : TEXTURE_3D, RGBA8, w : 1, h : 1, d : 1, comp : 4, size : 0.00 MiB
Using OpenGL 4.3 debug facilities
GL application marker: Successfully hooked OpenGL debug callback.
found bundled python: C:\Program Files\Blender Foundation\Blender 2.81\2.81\python
Warning: class subcustomPropertiesGroup contains a property which should be an annotation!
C:\Users\bry\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\FloatingWindows_V2.py:62

assign as a type annotation: subcustomPropertiesGroup.customString

Warning: class customPropertiesGroup contains a property which should be an annotation!
C:\Users\bry\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\FloatingWindows_V2.py:65

assign as a type annotation: customPropertiesGroup.subLists

Warning: class FloatWindowsPref contains a property which should be an annotation!
C:\Users\bry\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\FloatingWindows_V2.py:3109

assign as a type annotation: FloatWindowsPref.winaero
assign as a type annotation: FloatWindowsPref.IsPie
assign as a type annotation: FloatWindowsPref.IsPieFat
assign as a type annotation: FloatWindowsPref.IsPie2
assign as a type annotation: FloatWindowsPref.IsPin
assign as a type annotation: FloatWindowsPref.custom_01_name
assign as a type annotation: FloatWindowsPref.custom_01_icon
assign as a type annotation: FloatWindowsPref.custom_01_x
assign as a type annotation: FloatWindowsPref.custom_01_y
assign as a type annotation: FloatWindowsPref.custom_01_perc
assign as a type annotation: FloatWindowsPref.custom_01_cursor
assign as a type annotation: FloatWindowsPref.custom_01_loc_x
assign as a type annotation: FloatWindowsPref.custom_01_loc_y
assign as a type annotation: FloatWindowsPref.custom_01_show_debug
assign as a type annotation: FloatWindowsPref.custom_01_editor
assign as a type annotation: FloatWindowsPref.custom_01_hide_tn
assign as a type annotation: FloatWindowsPref.custom_01_hide_header
assign as a type annotation: FloatWindowsPref.custom_01_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_01_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_01_xray
assign as a type annotation: FloatWindowsPref.custom_01_wire
assign as a type annotation: FloatWindowsPref.custom_01_local
assign as a type annotation: FloatWindowsPref.custom_01_ortho
assign as a type annotation: FloatWindowsPref.custom_01_move
assign as a type annotation: FloatWindowsPref.custom_01_view
assign as a type annotation: FloatWindowsPref.custom_01_render
assign as a type annotation: FloatWindowsPref.custom_01_mode
assign as a type annotation: FloatWindowsPref.custom_01_3dwalk
assign as a type annotation: FloatWindowsPref.custom_01_home
assign as a type annotation: FloatWindowsPref.custom_01_focus
assign as a type annotation: FloatWindowsPref.custom_02_name
assign as a type annotation: FloatWindowsPref.custom_02_icon
assign as a type annotation: FloatWindowsPref.custom_02_x
assign as a type annotation: FloatWindowsPref.custom_02_y
assign as a type annotation: FloatWindowsPref.custom_02_perc
assign as a type annotation: FloatWindowsPref.custom_02_cursor
assign as a type annotation: FloatWindowsPref.custom_02_loc_x
assign as a type annotation: FloatWindowsPref.custom_02_loc_y
assign as a type annotation: FloatWindowsPref.custom_02_show_debug
assign as a type annotation: FloatWindowsPref.custom_02_editor
assign as a type annotation: FloatWindowsPref.custom_02_hide_tn
assign as a type annotation: FloatWindowsPref.custom_02_hide_header
assign as a type annotation: FloatWindowsPref.custom_02_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_02_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_02_xray
assign as a type annotation: FloatWindowsPref.custom_02_wire
assign as a type annotation: FloatWindowsPref.custom_02_local
assign as a type annotation: FloatWindowsPref.custom_02_ortho
assign as a type annotation: FloatWindowsPref.custom_02_move
assign as a type annotation: FloatWindowsPref.custom_02_view
assign as a type annotation: FloatWindowsPref.custom_02_render
assign as a type annotation: FloatWindowsPref.custom_02_mode
assign as a type annotation: FloatWindowsPref.custom_02_3dwalk
assign as a type annotation: FloatWindowsPref.custom_02_home
assign as a type annotation: FloatWindowsPref.custom_02_focus
assign as a type annotation: FloatWindowsPref.custom_03_name
assign as a type annotation: FloatWindowsPref.custom_03_icon
assign as a type annotation: FloatWindowsPref.custom_03_x
assign as a type annotation: FloatWindowsPref.custom_03_y
assign as a type annotation: FloatWindowsPref.custom_03_perc
assign as a type annotation: FloatWindowsPref.custom_03_cursor
assign as a type annotation: FloatWindowsPref.custom_03_loc_x
assign as a type annotation: FloatWindowsPref.custom_03_loc_y
assign as a type annotation: FloatWindowsPref.custom_03_show_debug
assign as a type annotation: FloatWindowsPref.custom_03_editor
assign as a type annotation: FloatWindowsPref.custom_03_hide_tn
assign as a type annotation: FloatWindowsPref.custom_03_hide_header
assign as a type annotation: FloatWindowsPref.custom_03_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_03_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_03_xray
assign as a type annotation: FloatWindowsPref.custom_03_wire
assign as a type annotation: FloatWindowsPref.custom_03_local
assign as a type annotation: FloatWindowsPref.custom_03_ortho
assign as a type annotation: FloatWindowsPref.custom_03_move
assign as a type annotation: FloatWindowsPref.custom_03_view
assign as a type annotation: FloatWindowsPref.custom_03_render
assign as a type annotation: FloatWindowsPref.custom_03_mode
assign as a type annotation: FloatWindowsPref.custom_03_3dwalk
assign as a type annotation: FloatWindowsPref.custom_03_home
assign as a type annotation: FloatWindowsPref.custom_03_focus
assign as a type annotation: FloatWindowsPref.custom_04_name
assign as a type annotation: FloatWindowsPref.custom_04_icon
assign as a type annotation: FloatWindowsPref.custom_04_x
assign as a type annotation: FloatWindowsPref.custom_04_y
assign as a type annotation: FloatWindowsPref.custom_04_perc
assign as a type annotation: FloatWindowsPref.custom_04_cursor
assign as a type annotation: FloatWindowsPref.custom_04_loc_x
assign as a type annotation: FloatWindowsPref.custom_04_loc_y
assign as a type annotation: FloatWindowsPref.custom_04_show_debug
assign as a type annotation: FloatWindowsPref.custom_04_editor
assign as a type annotation: FloatWindowsPref.custom_04_hide_tn
assign as a type annotation: FloatWindowsPref.custom_04_hide_header
assign as a type annotation: FloatWindowsPref.custom_04_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_04_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_04_xray
assign as a type annotation: FloatWindowsPref.custom_04_wire
assign as a type annotation: FloatWindowsPref.custom_04_local
assign as a type annotation: FloatWindowsPref.custom_04_ortho
assign as a type annotation: FloatWindowsPref.custom_04_move
assign as a type annotation: FloatWindowsPref.custom_04_view
assign as a type annotation: FloatWindowsPref.custom_04_render
assign as a type annotation: FloatWindowsPref.custom_04_mode
assign as a type annotation: FloatWindowsPref.custom_04_3dwalk
assign as a type annotation: FloatWindowsPref.custom_04_home
assign as a type annotation: FloatWindowsPref.custom_04_focus
assign as a type annotation: FloatWindowsPref.custom_05_name
assign as a type annotation: FloatWindowsPref.custom_05_icon
assign as a type annotation: FloatWindowsPref.custom_05_x
assign as a type annotation: FloatWindowsPref.custom_05_y
assign as a type annotation: FloatWindowsPref.custom_05_perc
assign as a type annotation: FloatWindowsPref.custom_05_cursor
assign as a type annotation: FloatWindowsPref.custom_05_loc_x
assign as a type annotation: FloatWindowsPref.custom_05_loc_y
assign as a type annotation: FloatWindowsPref.custom_05_show_debug
assign as a type annotation: FloatWindowsPref.custom_05_editor
assign as a type annotation: FloatWindowsPref.custom_05_hide_tn
assign as a type annotation: FloatWindowsPref.custom_05_hide_header
assign as a type annotation: FloatWindowsPref.custom_05_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_05_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_05_xray
assign as a type annotation: FloatWindowsPref.custom_05_wire
assign as a type annotation: FloatWindowsPref.custom_05_local
assign as a type annotation: FloatWindowsPref.custom_05_ortho
assign as a type annotation: FloatWindowsPref.custom_05_move
assign as a type annotation: FloatWindowsPref.custom_05_view
assign as a type annotation: FloatWindowsPref.custom_05_render
assign as a type annotation: FloatWindowsPref.custom_05_mode
assign as a type annotation: FloatWindowsPref.custom_05_3dwalk
assign as a type annotation: FloatWindowsPref.custom_05_home
assign as a type annotation: FloatWindowsPref.custom_05_focus
assign as a type annotation: FloatWindowsPref.custom_06_name
assign as a type annotation: FloatWindowsPref.custom_06_icon
assign as a type annotation: FloatWindowsPref.custom_06_x
assign as a type annotation: FloatWindowsPref.custom_06_y
assign as a type annotation: FloatWindowsPref.custom_06_perc
assign as a type annotation: FloatWindowsPref.custom_06_cursor
assign as a type annotation: FloatWindowsPref.custom_06_loc_x
assign as a type annotation: FloatWindowsPref.custom_06_loc_y
assign as a type annotation: FloatWindowsPref.custom_06_show_debug
assign as a type annotation: FloatWindowsPref.custom_06_editor
assign as a type annotation: FloatWindowsPref.custom_06_hide_tn
assign as a type annotation: FloatWindowsPref.custom_06_hide_header
assign as a type annotation: FloatWindowsPref.custom_06_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_06_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_06_xray
assign as a type annotation: FloatWindowsPref.custom_06_wire
assign as a type annotation: FloatWindowsPref.custom_06_local
assign as a type annotation: FloatWindowsPref.custom_06_ortho
assign as a type annotation: FloatWindowsPref.custom_06_move
assign as a type annotation: FloatWindowsPref.custom_06_view
assign as a type annotation: FloatWindowsPref.custom_06_render
assign as a type annotation: FloatWindowsPref.custom_06_mode
assign as a type annotation: FloatWindowsPref.custom_06_3dwalk
assign as a type annotation: FloatWindowsPref.custom_06_home
assign as a type annotation: FloatWindowsPref.custom_06_focus
assign as a type annotation: FloatWindowsPref.custom_07_name
assign as a type annotation: FloatWindowsPref.custom_07_icon
assign as a type annotation: FloatWindowsPref.custom_07_x
assign as a type annotation: FloatWindowsPref.custom_07_y
assign as a type annotation: FloatWindowsPref.custom_07_perc
assign as a type annotation: FloatWindowsPref.custom_07_cursor
assign as a type annotation: FloatWindowsPref.custom_07_loc_x
assign as a type annotation: FloatWindowsPref.custom_07_loc_y
assign as a type annotation: FloatWindowsPref.custom_07_show_debug
assign as a type annotation: FloatWindowsPref.custom_07_editor
assign as a type annotation: FloatWindowsPref.custom_07_hide_tn
assign as a type annotation: FloatWindowsPref.custom_07_hide_header
assign as a type annotation: FloatWindowsPref.custom_07_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_07_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_07_xray
assign as a type annotation: FloatWindowsPref.custom_07_wire
assign as a type annotation: FloatWindowsPref.custom_07_local
assign as a type annotation: FloatWindowsPref.custom_07_ortho
assign as a type annotation: FloatWindowsPref.custom_07_move
assign as a type annotation: FloatWindowsPref.custom_07_view
assign as a type annotation: FloatWindowsPref.custom_07_render
assign as a type annotation: FloatWindowsPref.custom_07_mode
assign as a type annotation: FloatWindowsPref.custom_07_3dwalk
assign as a type annotation: FloatWindowsPref.custom_07_home
assign as a type annotation: FloatWindowsPref.custom_07_focus
assign as a type annotation: FloatWindowsPref.custom_08_name
assign as a type annotation: FloatWindowsPref.custom_08_icon
assign as a type annotation: FloatWindowsPref.custom_08_x
assign as a type annotation: FloatWindowsPref.custom_08_y
assign as a type annotation: FloatWindowsPref.custom_08_perc
assign as a type annotation: FloatWindowsPref.custom_08_cursor
assign as a type annotation: FloatWindowsPref.custom_08_loc_x
assign as a type annotation: FloatWindowsPref.custom_08_loc_y
assign as a type annotation: FloatWindowsPref.custom_08_show_debug
assign as a type annotation: FloatWindowsPref.custom_08_editor
assign as a type annotation: FloatWindowsPref.custom_08_hide_tn
assign as a type annotation: FloatWindowsPref.custom_08_hide_header
assign as a type annotation: FloatWindowsPref.custom_08_hide_overlay
assign as a type annotation: FloatWindowsPref.custom_08_hide_gizmo
assign as a type annotation: FloatWindowsPref.custom_08_xray
assign as a type annotation: FloatWindowsPref.custom_08_wire
assign as a type annotation: FloatWindowsPref.custom_08_local
assign as a type annotation: FloatWindowsPref.custom_08_ortho
assign as a type annotation: FloatWindowsPref.custom_08_move
assign as a type annotation: FloatWindowsPref.custom_08_view
assign as a type annotation: FloatWindowsPref.custom_08_render
assign as a type annotation: FloatWindowsPref.custom_08_mode
assign as a type annotation: FloatWindowsPref.custom_08_3dwalk
assign as a type annotation: FloatWindowsPref.custom_08_home
assign as a type annotation: FloatWindowsPref.custom_08_focus
assign as a type annotation: FloatWindowsPref.cam_lock
assign as a type annotation: FloatWindowsPref.cam_header
assign as a type annotation: FloatWindowsPref.cam_overlay
assign as a type annotation: FloatWindowsPref.cam_render
assign as a type annotation: FloatWindowsPref.cam_recenter
assign as a type annotation: FloatWindowsPref.cam_auto_size
assign as a type annotation: FloatWindowsPref.cam_local
assign as a type annotation: FloatWindowsPref.show_debug
assign as a type annotation: FloatWindowsPref.show_debug1
assign as a type annotation: FloatWindowsPref.show_debug2
assign as a type annotation: FloatWindowsPref.show_debug3
assign as a type annotation: FloatWindowsPref.show_debug4

read file

Version 280 sub 57 date unknown hash unknown

read file

Version 280 sub 20 date 2018-07-14 11:44 hash 27ba739fb79

Error : EXCEPTION_ACCESS_VIOLATION
Address : 0x00007FF71F44E928
Module : C:\Program Files\Blender Foundation\Blender 2.81\blender.exe

This comment was removed by Bryan F (BryanF).

@Bryan F (BryanF) There's been a misunderstanding,

Sorry one more thing, I opened 2.81 and uploaded the files you suggested (cloud arrow key??)

I then went into 2.80 and deleted 'floating windows' addon and couldn't find Bpainter anywhere in the registry.

I then went into 2.81 'start up file' and now that is crashing.

@Bryan F (BryanF) Please remove the wall of text comments and upload the files.

@Bryan F (BryanF) Please remove the wall of text comments and upload the files.

Sorry about that, not actually sure how to upload the files required. Perhaps a better report a bug system can be developed by blender for us non programmers. Many other programs report bugs automatically.

Robert Guetzkow (rjg) added a comment.EditedThu, Dec 5, 4:27 PM

@Bryan F (BryanF) There is a screenshot in my previous reply which marks the upload button with a red rectangle. This button is can be found in the area where you leave a comment on this page. You have to click on in order to upload the files. I've added another screenshot below.

We currently don't have an automated crash reporting, because we value privacy and automated telemetry is not a good idea in that regard. The developers have been discussing solution that could improve the reporting, e.g. users could manually approve error/crash log uploads. Such as solution may be available in the future.