Page MenuHome

Pink Material Preview and Principled BSDF Shader
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362 64 Bits
Graphics card: Intel(R) HD Graphics 4000 Intel 4.0.0 - Build 10.18.10.5069

Blender Version
Broken: version: 2.81 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: rB26bd5ebd42e3
Worked: 2.80

Short description of error
Principled BSDF Shader produces a the usual pink material regardless of settings. The preview window of the materials shows a pink plain rather than the usual checkered plain that sits under the material.

Exact steps for others to reproduce the error
Not sure if its just my hardware or just a random bug, but this was a fresh install of blender 2.81. I just did a re-download 2.81 and repair to see if that helped; nope. I did update the Intel HD 4000 driver to most recent, and i was warned it may cause problems. Still get it even with the most to date driver. I usually operate all of blender off the NVidia GTX 1060 GPU and through CUDA. Works fine in Cycles, and is only apparent in Eevee.

...And while grabbing screenshots I just solved some of it. I did a factory reset to blender, switched between eevee to cycles, then back to eevee, and only once i got it switched to render mode did it update the shader, but not the preview. So maybe one less bug? Still going to send pics to help anyone else.

Event Timeline

Evan Wilson (EAW) lowered the priority of this task from 90 to 30.Dec 5 2019, 1:43 PM

Blender 2.80+ supports Intel generation Haswell and newer, Intel HD 4000 is from the previous generation Ivy Bridge , so this looks like it is a case of unsupported hardware.


Unsupported graphics card

Thanks for the report. This GPU is below the minimum requirements for Blender, so we no longer provide support for it. https://www.blender.org/download/requirements/

Installing the latest graphics driver sometimes helps to make such GPUs work, see here for more information. https://docs.blender.org/manual/en/dev/troubleshooting/gpu/index.html

If that doesn't help, you can use Blender 2.79: https://www.blender.org/download/previous-versions/


However, it isn't clear what you meant by the following:

I usually operate all of blender off the NVidia GTX 1060 GPU and through CUDA. Works fine in Cycles, and is only apparent in Eevee.

Do you mean that you use a different computer that has the GTX 1060 GPU, or is it this same computer? If it is the same computer, it looks like Blender isn't recognizing the NVidia card. Is that by choice on your end?

Philipp Oeser (lichtwerk) changed the task status from Unknown Status to Unknown Status.Dec 17 2019, 12:45 PM
Philipp Oeser (lichtwerk) claimed this task.

More than a week without reply or activity. Due to the policy of the tracker archiving for until required info/data are provided.