Page MenuHome

When using multiple desktops on Windows 10 and Blender is in full-screen mode on a desktop, desktop switching makes Blender act weirdly
Closed, InvalidPublic

Description

System Information
Operating system: Windows 10 (1909)
Graphics card: Intel HD 620

Blender Version
2.81a

Short description of error
When there are two desktops in Windows and Blender is on the second desktop in full-screen mode, switching the desktop to the other one and coming back to the Blender's desktop makes the Blender act weirdly. It shows the old dismissed UI element, or the whole application becomes black. If I move the mouse to the menu area, I can see the screen again, but then Blender still flickers with a black screen for things like opening the preference window.

Exact steps for others to reproduce the error

  1. Create two desktops in Windows 10. (Press Win+Tab, then click "New Desktop").
  2. Switch to the second desktop and start Blender.
  3. Go to full-screen mode.
  4. Switch to the first desktop using the touchpad gesture or pressing Ctrl+Win+Left arrow.
  5. Go back to the second desktop using the touchpad gesture or pressing Ctrl+Win+Right arrow.
  6. Try to open the preference window.

Event Timeline

I cannot repro the bad behavior here. I'm running the following:

Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 430.86
Version: 2.82 (sub 6), branch: master, commit date: 2019-12-23 22:37, hash: rBb450ba84d9dd

Jacques Lucke (JacquesLucke) changed the task status from Needs Triage to Needs Information from User.Jan 14 2020, 3:31 PM

I also cannot reproduce it.

Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: AMD Radeon RX 5700 ATI Technologies Inc. 4.5.13572 Core Profile Context 19.11.3
Version: 2.82 (sub 6), branch: master, commit date: 2020-01-13 17:12, hash: rBc56526d8b68a

Please check if you can update your gpu driver.

Can not reproduce
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: Radeon RX550/550 Series ATI Technologies Inc. 4.5.13586 Core Profile Context 19.12.2 26.20.15002.61

Can you re-try with latest development build? https://builder.blender.org/download/

Richard Antalik (ISS) closed this task as Invalid.Jan 26 2020, 2:33 AM
Richard Antalik (ISS) claimed this task.

Since last asking for information it has been 7 or more days, due to the policy of our bug tracker we will have to close the report.