Page MenuHome

Current version seems to not render fire while it still shows in viewport render, both Eevee & Cycles
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.82 (sub 5), branch: fluid-mantaflow, commit date: 2019-12-16 14:05, hash: rBed32db06c124
Worked: (optional)

Short description of error
[Fire does not show in F12 render, while it still shows in viewport rendered mode, both Eevee & Cycles.
It does render in the previous version if the scene is loaded, the domain has Fluid added again and the cache baked in the current version is chosen in the cache file path.
Here's a couple of screen grabs-
Current version


Previous version, same scene using cache baked in current version
]

Exact steps for others to reproduce the error
[Bake the attached blend to say frame 16, then bake noise, render frame 16, then try the blend with the same baked cache in the previous version.

]
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Can you please try to create an even simpler file that shows the issue? Everything that is not necessary should be removed.

Jacques Lucke (JacquesLucke) changed the task status from Needs Triage to Needs Information from User.Sat, Dec 28, 2:16 PM

So, I tried removing the smoke only emitter (cube object), and (of course), then Mantaflow renders properly, so normally my answer would be 'no, everything in the scene is necessary to show the bug'.

This time however you are in luck; I saw this bug before in a previous scene I built in the 26-12-19 build; but I didn't report it as a bug- because I just got a bit more depressed about Mantaflow in general for smoke, and moved on & forgot about it. Until it happened again in the scene I originally used in this report.


Broken in Cycles & Eevee, an emitter, a domain, a camera & a light: simple enough for you?

Philipp Oeser (lichtwerk) changed the task status from Needs Information from User to Needs Triage.Tue, Jan 7, 10:11 AM

Thx for getting back, needs another look then...

Mark Spink (marks) closed this task as Resolved.Wed, Jan 15, 9:15 AM
Mark Spink (marks) claimed this task.

Hello all

Stupidly (apparently) I've been using the Mantaflow version from the experimental builds page, this would appear to be out of date (and should be removed from the page- see my rant in my last comment on this bug T73078).

I've tried it in 2.83Alpha and it works (and in 2.82Beta).

This bug looks to be fixed...

Cheers All!