Page MenuHome

Issue with shared meshes overwriting modifiers
Closed, ResolvedPublicKNOWN ISSUE

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 980/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 425.31

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2019-12-26 19:15, hash: rBd35a31968707

Short description of error

All meshes that have shared mesh data (I mean they use same geometry)
will pop into the scene in edit cage display, regardless of what object you actually edit. Ok so far.

But in addition, they ignore their current modifier setup and use your currently
active object's modifiers to replace their own for the editing time. Why?

This creates bad visualization and editing conflicts, especially when
using those meshes heavily modified (Mask) and dependent on each other.

The current behaviour is very annoying to deal with.
I cant find a way to turn this off, therefore I assume its intended. Please correct me if this isnt true.
Otherwise see my file for a small showcase.

Exact steps for others to reproduce the error

Example:

  1. Add a Cube and give it a material.
  2. Create a linked duplication (alt-D) and give it a new material on the same slot (object material) with red color.
  3. Make sure they are placed on the same spot.
  4. Give the second Cube a Skin modifier.
  5. Select the first Cube and go into Edit mode.

Issue:
The first Cube is displayed red now while editing because the second Cube is rendered on top of it.
Issue 2:
You cant see at the same time whats going on for the second Cube with its own modifiers which might be relevant to the editing process. (for example hidden or skinned parts that are connected to the model)

Event Timeline

Karja Krähwald (karja) renamed this task from Issue with shared meshes overwriting modifiers and edit cage state to Issue with shared meshes overwriting modifiers.Dec 27 2019, 5:02 PM
Karja Krähwald (karja) created this task.
Jacques Lucke (JacquesLucke) changed the task status from Needs Triage to Confirmed.Dec 28 2019, 1:43 PM

Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Known Issue".Jan 15 2020, 11:01 AM

This will most certainly require quite a bit of work to get fixed, so considering it a known issue for now.

Jeroen Bakker (jbakker) closed this task as Resolved.Tue, Feb 4, 8:02 AM
Jeroen Bakker (jbakker) claimed this task.

THe first mentioned issue has been solved. The second part was already solved. Materials are part of the mesh and is shared between the objects.
I will mark this issue completed as I this has fixed based on the mentioned steps to reproduce.

If this is not the case, please open a new issue explaining in detail the steps needed to reproduce.