Page MenuHome

BlenderKit Crash with Fabric Materials
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.66

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2019-12-23 22:37, hash: rBb450ba84d9dd
Worked: (optional)

Short description of error
BlenderKit Crash with Fabric Materials

Exact steps for others to reproduce the error
Open BlenderKit Addon.
Click the Fabric Button.
After the Material samples appear on the screen Click Any Fabric Material.
Crash
[Based on the default startup]

Event Timeline

I can't replicate the crash in blender 2.83.

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: Radeon (TM) RX 480 Graphics ATI Technologies Inc. 4.5.13559 Core Profile Context 26.20.12037.1000

Addon Information
Name: BlenderKit Asset Library (1, 0, 28)

I think this might be due to the complexity of some materials for Eevee. Some procedural fabric materials we have in the database have far too many nodes, and Blender just crashes trying to process them. The weird thing is this happens with a GTX 1080.
I'm working on a fix, that basically hides more complex materials from EEVEE.
This however points to some deeper issue with shaders processing/compilation, that probably isn't connected to the addon. The addon technically just downloads the file, appends the material and links it to the mesh.

This is on TODO list where displayed Materials will be limited for EEVEE - complex materials won't simply be displayed there and there will be a warning. As of now, this isn't blenderkit bug - it's most probably EEVEE crashing because of too complex material setup.

Vilem Duha (pildanovak) closed this task as Resolved.Mar 18 2020, 12:59 PM