Page MenuHome

GPU open CL Cycles rendering not working
Closed, InvalidPublic

Description

System Information
Operating system: Linux-5.3.0-7625-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: Radeon RX 580 Series ATI Technologies Inc. 4.5.13572 Core Profile Context

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2019-12-30 18:20, hash: rB56ef761381ec
Worked: 2.81a works

Short description of error
This issue occurs only on the alpha/beta versions of Blender. In Blender 2.81a (stable) rendering with openCL goes through the usual procces of compiling the render kernel then everything is working perfectly, however on any release of the 2.82+ when switching to GPU OpenCL rendering blender kinda freezes, the ui seems responsive and interactible but there is nothing happending, can't close, click on anything, no info is displayed either compiling or rendering etc.
On the default opening scene i`ve left it for about an hour and nothing changed blender is frozen.

Event Timeline

Dan Pastean (Dan_P) renamed this task from GPU open CL rendering not working to GPU open CL Cycles rendering not working.Fri, Jan 3, 12:17 PM
Dan Pastean (Dan_P) created this task.
Dan Pastean (Dan_P) updated the task description. (Show Details)

I'm having the same issue! I hope this get addressed.

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Fri, Jan 10, 6:35 PM

Thanks for the report. But I can't reproduce the problem in the version indicated.
Can you provide a file demonstrating the problem?

It is good to keep in mind though that every new version of blender needs to recompile OpenGL material kernels.
Each kernel only needs to be compiled the first time.
Check the terminal to see if all kernels are compiled.

Saddly i can`t anymore.
while trying to update the mesa drivers and the kernel to see if it helps i`ve messed up the system and had to reinstall the OS from scatch. Using the same kernel had to manually install amd`s drivers and because its not oficially suported for my newer version of OS. Now the kernel compiled everything perfectly and i cant explain how it works since i`m still learning to use linux as a main OS.
Before the kernel would have compiled in version 2.81a and in the alpha it would have just frozen, even opening it with the terminal gave no info as the terminal also froze before it got a chance to compile.
I quess the topic is closed due to incorect driver installation or broken AMD installation scripts.

Richard Antalik (ISS) closed this task as Invalid.Sun, Jan 19, 11:53 PM
Richard Antalik (ISS) claimed this task.

Thanks for update.