Page MenuHome

Blender crashes on Windows
Closed, ArchivedPublic

Description

System Information
Operating system: Windows 10
Ryzen 1700
Graphics card: Nvidia GTX 1080
16gb RAM

Blender Version
Broken: 2.81a

Short description of error

Disappointing...attempting to move to Blender from Modo and Cinema 4D.
I'm under the gun to get up to speed in Blender, and can't work like this.

Blender crashes to desktop, or to black screen requiring hard reboot.
This happens while in render preview mode with a VERY simple scene (donut tutorial, with just donut and icing)
No silly subdivision levels, experienced in 3D, just new to Blender.

Video card drivers are up to date, (just updated) card is not overclocked.

Also will crash during an actual render.
Stable in other modes.

Exact steps for others to reproduce the error
Enter rendered viewport mode, move/dolly around...or do a render.
Renders did not crash at all until I zoomed in.

My system is stable with Cinema, Modo, Photoshop, very large/demanding files etc.

Please help.

Related Objects

Event Timeline

Forgot to mention, 4K monitor.

Campbell Barton (campbellbarton) changed the task status from Needs Triage to Needs Information from User.EditedJan 8 2020, 3:37 AM
Campbell Barton (campbellbarton) renamed this task from Crash Crash Crash to Blender crashes on Windows10, Nvidia GTX 1080.Jan 8 2020, 3:37 AM
Campbell Barton (campbellbarton) renamed this task from Blender crashes on Windows10, Nvidia GTX 1080 to Blender crashes on Windows.

Thanks for the help. 3 slightly different tries below, no luck.
I'm not that experienced running things from the command prompt.
What am I doing wrong?
Path is C:\Program Files\Blender Foundation\Blender 2.81

C:\Users\Gambit>Program Files\Blender Foundation\Blender 2.81\blender.exe
'Program' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Gambit>\Program Files\Blender Foundation\Blender 2.81\blender.exe
'\Program' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Gambit>Program Files\Blender Foundation\Blender 2.81\blender.exe
'Program' is not recognized as an internal or external command,
operable program or batch file.

The executable name needs to be in quotes as there are spaces in the path.

Try either changing into the blender directory first and then executing blender.exe:

C:\Users\Gambit> cd "\Program Files\Blender Foundation\Blender 2.81"
C:\Users\Gambit>blender.exe

or you can try putting the command in double quotes, such as:

C:\Users\Gambit>"\Program Files\Blender Foundation\Blender 2.81\blender.exe"

Just start blender with the blender_debug_log.cmd located next to the blender executable, and follow the instructions.

I'm impressed already with how helpful you guys are.
I'll definitely be contributing to this project.
Thank you.

Took me a minute of dragging around, but got a crash in under a minute.
Here are the debug files.

Incidentally I found this post while searching today on my lunch-break.
Let me know if you think it relates to my crash issues.

2.81 Nvidia Crash

Thanks again.

Jim

I need something here so that I don't lose hope, give up on Blender and go update my Modo 901 license to 13.

Any insight? Is this being worked on? Same bug referenced above in the other thread?
Workaround?

Could you check other versions? Do you have crashes in 2.79, 2.80, and daily builds?

I will check.

Today's build crashes.
I will check 2.8.

OK - interesting.
While I haven't spent enough time in 2.8 to declare the problem non-existent...in 15 minutes of testing the file, moving around the "rendered" view port, and doing test renders I did not experience any crashes.
I did 5 or 6 renders.

So 2.81a - crash, stable build as well as today's daily build.

2.8 - no crash thus far.

JimM (JimM) added a comment.EditedJan 12 2020, 4:10 AM

2.8 just crashed to black screens during the same simple render/scene.

/me bets on the video driver... just because.

Latest driver, system is rock solid/stable with everything else.

Do I need to provide anything else?
Latest daily builds do not seem to crash while moving around the rendered viewport, and will sometimes render the simple donut scene without crashing...however crashes still occur half the time at least while rendering.
Sometimes just the app, sometimes crashing to system to a black screen.

JimM (JimM) added a comment.EditedJan 17 2020, 3:22 AM

Data point - turning off my second monitor, a small 1400 pixel unit seems to have stopped the crashes for now.
Data point 2 - I was able to render in Cinema 4D, VERY large high res files, 6K textures, with BOTH monitors on, on my OLD video card, a GTX 780, with my i5 2500K processor.

This is a more powerful system in all respects, GTX 1080, Ryzen 1700 and shouldn't be having this issue.
So while I seem to have a work-around for the moment, I want to be clear that it's still very much an inconvenient bug. Especially since I'm rendering with my CPU to boot.

@JimM (JimM) Can you try to update GPU driver?

I looked at report T72985: CUDA error following same tutorial and with similar HW.

Regarding:

Data point - turning off my second monitor, a small 1400 pixel unit seems to have stopped the crashes for now.

Suggest to close this report since it seems like a hardware/driver bug, not caused by a bug in Blender.

JimM (JimM) added a comment.EditedJan 27 2020, 8:45 AM

I would tend to disagree since Blender is the only application that causes this crash behavior.
If it were a hardware/driver bug then A, I'd be getting crashing with other demanding applications, and B I wouldn't be seeing these same crash reports from multiple other users.

Now all of that doesn't make it a given that it's NOT a device/driver bug, but evidence on my end points that direction.
If you ignore the fact that Blender is the only thing that crashes, then sure, looks like a hardware/driver bug for sure.

Again, I updated the driver upon first experiencing this crash and it didn't solve the problem.
Going to a daily build stopped the render viewport crash, but the actual render crash continued though not with every single render....maybe half the time...and again short, render/simple scene.

So again, not pointing to a hardware/driver bug from where I sit.

A short vacation and getting pulled to another non-3D task means I haven’t been able to continue experimenting over the last week.

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Ankit Meel (ankitm) closed this task as Archived.May 1 2020, 5:50 PM
Ankit Meel (ankitm) claimed this task.

If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.