Page MenuHome

Cloth Simulation Rig behaves like jelly/jello in 2.8 and behaves gently in 2.79
Closed, ArchivedPublicBUG

Description

System Information
Operating system: Windows 10
Graphics card: Nvidia GTX 1080

Blender Version
Broken: 2.80 (sub 75), branch: master, commit date: 2019-07-29 14:47, hash: f6cb5f54494e

2.81 (sub 16), branch: master, commit date: 2019-12-04 11:32, hash: f1aa4d18d49d

Worked: 2.79, d7cecc2ba3f6

Short description of error
Using a tutorial blend file for Hair rigging which utilizes cloth simulation, the cloth simulation behaves as expected in 2.79; however when that same blend file is opened in 2.8 the simulation breaks and behaves like jello/jelly when a much smoother, gentle behavior was expected/desired.

Edit: I have determined that object scale seems to play a huge role in the observed behavior of physics objects (Rigid Body, Cloth Sim, etc). In a scene at 1x scale (relative to Blender cube) most physics don't work as expected, being very unstable/bouncy/jiggly. However in a clean test scene at 8x scale, physics was much more "damped" smooth, and the parameters seem to actually have an affect when changed. Applying scale at 8x did not result in 1x behavior. Adjusting mass has no effect.

Exact steps for others to reproduce the error
Load the attached blend file in 2.79, play the animation/timeline and manipulate the "head"/root bone of the setup'd rig, particular with r+z and then rotate it along the z axis left to right and back and observes its behavior. Then, open the same blend file in 2.8 and repeat, observe that the behavior is now different.

Event Timeline

Elison G. Bradley (RaenirSalazar) renamed this task from Cloth Simulation behaves like jelly/jello in 2.8 and behaves gently in 2.79 to Cloth Simulation Rig behaves like jelly/jello in 2.8 and behaves gently in 2.79.Jan 12 2020, 6:58 AM

I can confirm that the simulation is a bit different in 2.79 vs latest master. I a simple keyframe animation to make the simulation more reproducable.

Notice how the object slows down much more quickly in 2.79.

I'm not sure if that qualifies as a bug. @Sebastian Parborg (zeddb), can this be related to your work on cloth?

I can confirm that the simulation is a bit different in 2.79 vs latest master. I a simple keyframe animation to make the simulation more reproducable.

Notice how the object slows down much more quickly in 2.79.

I'm not sure if that qualifies as a bug. @Sebastian Parborg (zeddb), can this be related to your work on cloth?

When I'm home I can provide additional videos to reproduce the issue I am describing; but basically as you can see the issue I'm reporting involves the excessive bounciness/wobble/wobbliness of the cloth sim in 2.8+ vs 2.79 where there is virtually zero bounce/wobble. It's noticeable just how different the level of bounciness/wobbliness is, in the 2.8 example in your video you can see that the sim never settles, it just bounces forever and has the behavior reminiscent of jello/jelly/gelatin.

I'm trying to adapt this tutorial blend file for a hair rig in my own project and the result is a rig that bounces so much that it has no similarity to what I am trying to achieve (hair).

This is because velocity dampening was removed during the big cloth cleanup/rewrite.

@Luca Rood (LucaRood) I'm guessing that it might have been removed because the newer cloth code was more stable?
(So adding it back in would be fine for cases like this I guess...)

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Feb 19 2020, 11:17 AM
Richard Antalik (ISS) changed the subtype of this task from "Report" to "Bug".
Luca Rood (LucaRood) closed this task as Archived.Feb 22 2020, 4:41 PM

This is not a bug. The cloth simulator changed significantly in the 2.80 release, and we cannot support the behaviour that existed in 2.79.

Velocity damping was a horrible hack, and should never have been there in the first place. And it wasn't even very useful, considering how sensitive that setting was.

The cloth simulator in 2.8x has a completely rethought physical model, and one cannot expect it to behave the same way with the same settings. I have tried to keep the simulations as consistent as possible, by remapping necessary values in the versioning code, but manual intervention is still often necessary.

I would strongly discourage anyone from following a 2.79 cloth tutorial in 2.8x, as many settings behave differently, others have been removed, and many new settings were added.

All that being said, no significant functionality has been lost. One can still achieve comparable results by tweaking the settings that do exist in 2.8x.
The setting most similar to the old velocity damping is "Air Viscosity", so tweaking that is a good start. Also keep in mind that the old velocity damping "feature" would interfere with the behaviour of other settings, causing them to behave improperly, so when upgrading to 2.8x without the velocity damping, other settings might need to be changed as well, as they now actually behave as intended.

In the video below, I approximated the 2.79 behaviour in 2.82 by setting the Air Viscosity to 8, Vertex Mass to 0.1, and Pin Stiffness to 0.1 (the mass change is to compensate for the change in dampening behaviour, and the pin stiffness change is to compensate for the lowered mass).

Lastly, we do not currently completely support edge-only cloth simulations, as we are lacking proper bending springs for them. Actually, implementing the hair bending springs for generic cloth sims could be a nice task for someone looking to get started with physics development in Blender ;)

Thanks for the explanation and showing which settings to use instead.

After hacking the old velocity damping in again and testing it out, I agree with your assertion.
I don't think it should be brought back.