Page MenuHome

Blender autokeying deselects objects channels but not Armatures.
Closed, ArchivedPublicKNOWN ISSUE

Description

System Information
Windows 10 64 Bits.
Graphics card GeForce GTX 1080 Ti.

Blender Version
Broken: version: 2.83 hash: 4b6ce694c2b2

Short description of error
Is this supposed to happen or because Blender handles Armatures and Objects differently for Animation?

Exact steps for others to reproduce the error

  • Enable Autokeying.
  • Enable "Insert only needed" and "Only insert Avaliable" in Preferences ->Animation->Autokeying.
  • open the file.
  • Rotate the Armature, the Z channel doesn't get deselected.
  • Select the Cube and rotate, the Z Channel gets deselected.

[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Jan 20 2020, 2:30 PM
Sybren A. Stüvel (sybren) claimed this task.
Sybren A. Stüvel (sybren) changed the subtype of this task from "Report" to "Known Issue".

The synchronisation between selection state in the 3D viewport and the challens list is a known weak area. I've added this report to my list on my Weak Areas of Animation wiki page.

The synchronisation between selection state in the 3D viewport and the challens list is a known weak area. I've added this report to my list on my Weak Areas of Animation wiki page.

There are few other areas with similar issues but since you guys are aware of them then I guess it's best to wait until some work is done to them before making any new reports.