Page MenuHome

Eevee renders full frame and cut it instead region rendering
Confirmed, LowPublicKNOWN ISSUE

Description

System Information
Operating system: Windows-7-6.1.7601-SP1 64 Bits
Graphics card: GeForce GTX 660 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.20

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2020-01-19 22:44, hash: rB81b7f8efaf7a

Short description of error
I tested with same settings and I have the same time for whole frame and region.


It makes problem, when I want to render small part zoomed. Now the workaround — is making new camera with smaller angle and render from it.
If it is limitation, may be render should create temporary camera that cuts region.

Exact steps for others to reproduce the error
Render same scene with Eevee through F12 and it`s region and compare render time.

Event Timeline

Vyacheslav (hitrpr) updated the task description. (Show Details)
Pasang Bomjan (irex124) changed the task status from Needs Triage to Confirmed.Jan 21 2020, 3:50 PM

I can confirm. The render time is the same even with a render region of just a couple of pixels. It doesn't happen in cycles.

Campbell Barton (campbellbarton) closed this task as Invalid.EditedJan 21 2020, 4:06 PM

Use the crop option to render a smaller region: https://docs.blender.org/manual/en/latest/render/output/settings.html#dimensions-panel

This speeds up the render in your test file.

Use the crop option to render a smaller region: https://docs.blender.org/manual/en/latest/render/output/settings.html#dimensions-panel

This speeds up the render in your test file.

I already use it. And render time the same.
Please test it.

The render times are the same even when Render Region and Crop options are ticked, around 8/9 seconds. I mean it should reduce render times according to the docs. If it's a limitation then the documentation should state so.

Campbell Barton (campbellbarton) reopened this task as Needs Developer to Reproduce.Jan 23 2020, 8:51 AM

I can only confirm the speed is faster when rendered with a cropped border.

Assigning to @Clément Foucault (fclem)

Clément Foucault (fclem) changed the subtype of this task from "Report" to "Known Issue".Jan 23 2020, 12:08 PM

Yes, it is known that EEVEE always renders the fullframe. This is more of a TODO than anything else. But I don't have plans to fix it in the near future so I'll tag it as known issue.

@Clément Foucault (fclem), got it.
Fortunately, there is two workarounds to check only region (viewport render or second camera).

Richard Antalik (ISS) changed the task status from Needs Developer to Reproduce to Confirmed.Nov 25 2020, 7:55 PM

Confirming since this is already classified.

Vyacheslav (hitrpr) renamed this task from Eevee renders full frameand cut it instead region rendering (bug or limitation?) to Eevee renders full frame and cut it instead region rendering (bug or limitation?).Nov 26 2020, 9:41 AM
Vyacheslav (hitrpr) renamed this task from Eevee renders full frame and cut it instead region rendering (bug or limitation?) to Eevee renders full frame and cut it instead region rendering.