Page MenuHome

X-Ray Mode - snapping through object stop working on value = 1
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.66

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2020-01-23 15:59, hash: rB517870a4a11f
Worked: (optional)

Short description of error
As you read in title - snapping through objects stop work on X-Ray value equal 1. It work on full range of values from 0 to 0.999 but on 1 it just don't work. GIF capture

I checked - it work same in all 2.8X versions. So I don't exactly understand is it a bug or is it such " feature ". I have asked on devtalks but no one reply.

IMO - it's a bug.

  1. When I enable X - Ray mode it mean that I want to work through objects and snap through objects....
  2. Here GIF how look my scene with any values different than 1 - it look like some mess, impossible to work, so I need this 1 to be able to do my work same as I do it in 2.79.

Exact steps for others to reproduce the error
Just set X- Ray value to 1 in any 2.8X Blender....

Event Timeline

I think it's a bug. If we can select through the x-ray then it should snap as well.

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.Fri, Jan 24, 1:58 PM
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".

It is a bug. I'm investigating...

It is a bug. I'm investigating...

... closed this task as Resolved ...

Thank you for a lot !!! You my hero :)