Page MenuHome

Blender doesn't respond while selecting system console and saving or opening another file
Closed, InvalidPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: Intel(R) HD Graphics 4600 Intel 4.3.0 - Build 20.19.15.5058

Blender Version
Broken: 2.70 - 2.81.16 and 2.82 (sub 6), branch: master, commit date: 2020-02-02 08:28, hash: rBf51286cb8cc8
Worked: ... - 2.69 (when saving, but not when opening files)

Short description of error
Blender doesn't respond while selecting system console and saving or opening another file

Exact steps for others to reproduce the error

  • Toggle system console

  • Select any text or space in it

  • Save the file or open another without closing nor deselecting the text in the system console

  • Not respond

Note: It works again when deselecting the text in the system console

Odd behavoir: It does work when saving in 2.69 and olders, but doesn't when opening files

Event Timeline

It's not clear to me how anything like that in the system console could affect Blender. Could you be more clear about what you mean with system console? Just to be sure we're talking about the same thing.
In case we are, this would be a Windows only issue.

Julian Eisel (Severin) changed the task status from Needs Triage to Needs Information from User.Tue, Feb 4, 5:20 PM

I can confirm this issue using rB6b9062508a46

Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 470/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 388.13

Can confirm program not responding, not crash.

stuck at printf("Read blend: %s\n", filepath);

	blender.exe!BKE_blendfile_read(bContext * C, const unsigned char * filepath, const BlendFileReadParams * params, ReportList * reports) Line 417	C
 	blender.exe!WM_file_read(bContext * C, const unsigned char * filepath, ReportList * reports) Line 636	C
 	blender.exe!wm_open_mainfile__open(bContext * C, wmOperator * op) Line 2239	C
 	blender.exe!wm_handler_fileselect_do(bContext * C, ListBase * handlers, wmEventHandler_Op * handler, int val) Line 2265	C
 	blender.exe!wm_handlers_do_intern(bContext * C, wmEvent * event, ListBase * handlers) Line 2749	C
 	blender.exe!wm_handlers_do(bContext * C, wmEvent * event, ListBase * handlers) Line 2802	C
 	blender.exe!wm_event_do_handlers(bContext * C) Line 3181	C
 	blender.exe!WM_main(bContext * C) Line 421	C
 	blender.exe!main(int argc, const unsigned char * * UNUSED_argv_c) Line 520	C
 	[Externí kód]

As soon as you cancel selection in console, execution continues

I may add, that when I quit Blender during debugging session (MSVC), console will wait for key press. I am not able to start new session until I make key press.

Richard Antalik (ISS) changed the task status from Needs Information from User to Confirmed.Wed, Feb 5, 11:02 AM

Can confirm program not responding, not crash.
stuck at printf("Read blend: %s\n", filepath);

	blender.exe!BKE_blendfile_read(bContext * C, const unsigned char * filepath, const BlendFileReadParams * params, ReportList * reports) Line 417	C
 	blender.exe!WM_file_read(bContext * C, const unsigned char * filepath, ReportList * reports) Line 636	C
 	blender.exe!wm_open_mainfile__open(bContext * C, wmOperator * op) Line 2239	C
 	blender.exe!wm_handler_fileselect_do(bContext * C, ListBase * handlers, wmEventHandler_Op * handler, int val) Line 2265	C
 	blender.exe!wm_handlers_do_intern(bContext * C, wmEvent * event, ListBase * handlers) Line 2749	C
 	blender.exe!wm_handlers_do(bContext * C, wmEvent * event, ListBase * handlers) Line 2802	C
 	blender.exe!wm_event_do_handlers(bContext * C) Line 3181	C
 	blender.exe!WM_main(bContext * C) Line 421	C
 	blender.exe!main(int argc, const unsigned char * * UNUSED_argv_c) Line 520	C
 	[Externí kód]

As soon as you cancel selection in console, execution continues
I may add, that when I quit Blender during debugging session (MSVC), console will wait for key press. I am not able to start new session until I make key press.

I haven't noticed that. I'll change description. And also I changed the title, as I was mistaken about the crash

Gerard Taulats Braos (Tabra) renamed this task from Crash while selecting system console and saving or opening another file to Blender doesn't respond while selecting system console and saving or opening another file.Wed, Feb 5, 12:19 PM
Gerard Taulats Braos (Tabra) updated the task description. (Show Details)

If there's no crash, I wouldn't count this as a bug.
The console on windows always blocks if text is selected, and every software I know behaves like this.

I believe this is also used as a "feature" by some, in order to pause rendering.

I can confirn that it is a bug. As I mentioned in the description of the problem, in blender 2.69 and in older versions worked with the same set up that in recent versions stops working

Philip Holzmann (Foaly) closed this task as Invalid.Mon, Feb 10, 6:06 PM
Philip Holzmann (Foaly) claimed this task.

I just tried this on Windows 7 64 bit with Blender 2.68, and it hangs just the same when opening a file while selecting something in the console.

This is not a bug; Windows blocks stdout when selecting something in the console, and since Blender logs something to the console on loading it has to wait.
This is intended.

The description still mentions a crash, but you said you were mistaken, so I see nothing to do here.

Okay now... This is strange. I just downloaded 2.68 and I did the tests. It turns out that with 2.68 version, it allows you to save, but not to open files, while in 2.7 and newer can't save nor open

@Gerard Taulats Braos (Tabra) This is caused by the QuickEdit-Mode of the console and is unrelated to Blender. Perhaps some versions of Blender do not print to stdout when saving the file, which would avoid the freeze.