Page MenuHome

"Texture properties" tab hidden after creating "New Scene"
Confirmed, NormalPublicKNOWN ISSUE

Description

System Information
version: 2.81 (sub 16), branch: master, commit date: 2019-12-04 11:32, hash: f1aa4d18d49d, type: Release
build date: 2019-12-04, 14:30:40
platform: Windows

Graphics card: GeForce 1080 Ti

Short description of error
After adding a New Scene in Blender, the Texture properties tab in the Properties window is missing.

Exact steps for others to reproduce the error
See my attched image to reproduce the error in detail, please.

  1. Start with empty scene
  2. Add a New Scene inside your scene by creating a "Scene.001"
  3. Texture properties are hidden in "Scene.001"

This happens in v2.82 too.

Is this a bug or do I miss something, please?

Event Timeline

Evan Wilson (EAW) closed this task as Invalid.Wed, Feb 5, 4:40 PM
Evan Wilson (EAW) claimed this task.

There is nothing in the scene that can have a texture, because, well, there is nothing in the scene. =)
As soon as you add something, like a cube, and go to texture paint (which adds brushes) or add a modifier that can be modified with a texture, the texture properties tab will appear.

It's still hidden if you create an object afterwards.
So how to get the texture properties tab back?

Did you change from Object mode to Texture Paint mode after adding the cube, which causes brushes that can use textures to appear? Or did you add a modifier like Displacement that can use a texture to the cube?

Did you change from Object mode to Texture Paint mode after adding the cube, which causes brushes that can use textures to appear? Or did you add a modifier like Displacement that can use a texture to the cube?

Yes. This is a workaround. But if I set a texture in sculpt mode, the texture properties tab keeps hidden. Should it not be visible?
For me it's still a bug, to not to see the texture properties after adding a new scene. Am I wrong?

Evan Wilson (EAW) reopened this task as Needs Triage.Wed, Feb 5, 6:23 PM

I am now away from my computer (passenger in a car at the moment) so I cannot confirm. I would think that if you added a texture to a brush, it should appear. I will reopen this so it appears to other triagers. If no one gets to it, I’ll take another look tonight when I get back to my computer.

Evan Wilson (EAW) removed Evan Wilson (EAW) as the assignee of this task.Wed, Feb 5, 6:24 PM

Also, if you could please upload a simple .blend file showing the brush with an added texture but no texture properties tab in the new scene, that would be most helpful.

Of course. See the example scene below.

Thank you

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Thu, Feb 6, 7:16 PM

Caused by lazy-loading of ToolSettings. So this probably won't be bug.

You can add any mesh to scene, go to texture paint mode and icon will re-appear.

It's maybe not really a bug, but no user understand, why the default scene at Blender start has all tabs, including the texture tab and adding a new scene hasn't one.

The reason why I've posted this issue:
I add new empty scenes for composing external images or rendering other sub scenes e.g. So I need the textures tab to create procedural textures for fx in compositing without using any objects. I render just the compositing data.

So I don't understand why I have to create a model with texture data first, before I can see the texture tab. I hope the everything nodes project will change this in the future.

Thank you

So the issue here may be that user should be able to create new texture from within texture input node.

So the issue here may be that user should be able to create new texture from within texture input node.

This would be a good solution for all node based areas. But the problem is, currently you can't create a pocedural "blender cloud texture" that can be used in the material editor for example.
So there are some more issues to be kept in mind when trying to add such a feature.

Julian Eisel (Severin) changed the subtype of this task from "Report" to "Known Issue".EditedTue, Feb 18, 5:18 PM

I fixed a related bug, see rB9b243b9a53ca.

Like mentioned, texture paint data is lazy-initialized when you change into texture paint mode. I'm not sure if that's worth it really, checking the code, it just sets a few values, does three allocations and there's one lookup in the main brush list. Nothing that I think should be done lazily, we'd only have to do it when initializing a scene.
This is how we could easily address this:

1diff --git a/source/blender/blenkernel/intern/scene.c b/source/blender/blenkernel/intern/scene.c
2index fd1f030c3d3..d5a903c0fe5 100644
3--- a/source/blender/blenkernel/intern/scene.c
4+++ b/source/blender/blenkernel/intern/scene.c
5@@ -69,6 +69,7 @@
6 #include "BKE_fcurve.h"
7 #include "BKE_freestyle.h"
8 #include "BKE_gpencil.h"
9+#include "BKE_global.h"
10 #include "BKE_icons.h"
11 #include "BKE_idprop.h"
12 #include "BKE_image.h"
13@@ -676,6 +677,10 @@ void BKE_scene_init(Scene *sce)
14 BKE_color_managed_view_settings_init_render(
15 &sce->r.bake.im_format.view_settings, &sce->r.bake.im_format.display_settings, "Filmic");
16
17+ /* Initialize texture painting for this scene.
18+ * We could lazy-initialize, but that would be visible in the UI, see T73611. */
19+ BKE_paint_init(G_MAIN, sce, PAINT_MODE_TEXTURE_3D, PAINT_CURSOR_TEXTURE_PAINT);
20+
21 /* GP Sculpt brushes */
22 {
23 GP_Sculpt_Settings *gset = &sce->toolsettings->gp_sculpt;

I'll leave that up to the module team to decide though, @Jeroen Bakker (jbakker), @Bastien Montagne (mont29) and @Campbell Barton (campbellbarton).

In any case, code is behaving as expected. This is more of a usability issue, so will leave it open as known issue, until we evaluated the possible solution.