Page MenuHome

Clicking on another object on Outliner while in Pose Mode makes you get "stuck" in Pose Mode
Closed, InvalidPublic

Description

System Information
Operating system: Darwin-19.0.0-x86_64-i386-64bit 64 Bits
Graphics card: AMD Radeon Pro 560X OpenGL Engine ATI Technologies Inc. 4.1 ATI-3.2.24

Blender Version
Broken: version: 2.82 (sub 6), branch: master, commit date: 2020-02-04 20:36, hash: rB93a46f7d0897
Worked: (optional)

Short description of error
If you click on another object on the Outliner while in Pose Mode it doesn’t get selected. This is normal behaviour. But if you try to click on the viewport to get out of Pose Mode you get a “No Object Selected” alert. If you try to select any bones to get out of it it still shows the same. The only way is to find the rig on the Outliner again, click on it then get out of Pose Mode > Then you’re free. I think the way it should work would be by allowing yourself to get out of Pose Mode after you’ve selected the other object in the Outliner (or) take it off Pose Mode automatically (or) Not allow the selection, so you could get out of Pose Mode then select it, which is what you’re already able to do (with fewer steps this way).

Exact steps for others to reproduce the error
Create an Armature, click on another object on the outliner, try to switch to Object Mode.

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Feb 12 2020, 12:09 AM

Does your steps to reproduce apply to default startup file?
Does this happen when you click on File > Defaults > Load Factory Settings?
Can you check if this happens in latest build? https://builder.blender.org/download/

Gabriel Moro (gabrielmoro) claimed this task.

It doesn't when I reset to default... I'll have to rebuild my keymap because something old might be lingering there. But thanks and sorry for the trouble!