Page MenuHome

The tools in the new toolbar (2.8X) totally conflict with the hotkeys of the Mesh mode.
Needs Information from User, NormalPublic

Description

For example, I'd already set a hotkey "Shift + C + Tweak-Left-East" for Connect Vertex Pairs. But while the Select Box tool (new toolbar) was active, my hotkey for Connect Vertex Pairs wouldn't work at all. It seems like the input priority of Select Box tool is too high, and Blender doesn't take account of the modifier key "C" at all when an input conflict exists. If I disabled the "Shift select mode" hotkey of Select Box, my hotkey would work again. I used heavily these "Shift/Ctrl/Alt + C (any modifier key) + Tweak-Left-Any" style hotkeys in my workflow, so the input conflict of new tool bar can be a big problem to me. I think this can be easily fixed if you change the input priority of the new tool bar.

I'd done a quick experiment adding my hotkey on top of the "Shift select mode" hotkey of Select Box. My hotkey can work properly too. But it's not an elegant solution.

Event Timeline

You're creating a hotkey in the toolbar section. Add your hotkey in 3D View > Mesh > Mesh (Global) and it will work as you expected.

Philipp Oeser (lichtwerk) changed the task status from Needs Triage to Needs Information from User.Thu, Feb 13, 5:50 PM

You're creating a hotkey in the toolbar section. Add your hotkey in 3D View > Mesh > Mesh (Global) and it will work as you expected.

@Eva (sweep2rails): please try the above ^ and report back if that fixes it for you.

Eva (sweep2rails) added a comment.EditedThu, Feb 13, 8:53 PM

You're creating a hotkey in the toolbar section. Add your hotkey in 3D View > Mesh > Mesh (Global) and it will work as you expected.

@Eva (sweep2rails): please try the above ^ and report back if that fixes it for you.

It doesn't work at all, that's why I reported this bug.
So I just added the hotkey in the toolbar section for experiment purpose, and I indicated the only working case in the picture I posted.