UI: Code Quality Improvements - Low-Hanging Fruits to be Discussed
There are many major issues with the quality of our UI code. The argument can be made that much of it is due for a complete rewrite. Such a rewrite is not a short-term goal though. For that reason we should try addressing some low-hanging fruits within regular development.
The following isn't a complete list of low hanging fruits. It's more of an initial idea list.
Reducing bContext dependencies
bContext provides a handy way of passing around state information. The UI code probably relies too much on it though:
- It's become a real hassle to ensure it's valid as needed
- There are multiple cases where we know it's not set correctly, but fixing it is difficult. E.g. see T73565.
- Often passes around redundant data. E.g. some parameter lists include both wmWindow * and bContext * (itself also including a wmWindow *) - which window should be used? Can we rely on them being the same, or when do they differ?
- Testing the UI code is difficult either way, but removing dependencies on context, and only passing around actually needed data, should make units more isolated, thus more testable.
Ideally, I think context should only be passed to high-level operator, drawing or handler functions and the like. These should then read out needed data from context and use that to perform actions on this data as input. In-between these callbacks there should not be any access to the context.
Plan of action:
- Get rid of bContext * usage in lower level functions or we it can be easily avoided (see P1250).
- Add utility structures to wrap common UI data to operate on (wmWindow, bScreen, ScrArea, etc.).
- Add more sanity checks for context state.
Maybe we should also look into only actually creating a context when it's needed for callbacks. Making that easy and reliable isn't a low-hanging fruit though.
Push/pop bContext semantics
There are more and more places where we temporarily override context members, which always follows the same pattern. It's a good idea to generalize this, for esthetical reasons but also to prevent errors (e.g. single variables not reset in certain execution paths). We could introduce a simple and lightweight static context stack with push and pop calls to wrap any temorary overrides.
I'd like to point out a pitfall that I still stumble over occasionally after six years: the naming conventions for ARegion - ar and ScrArea - sa. When trying to access an area, it easy to mistakenly type ar, which refers to the region instead.
We should avoid such ambiguous names. We should also avoid abbreviations, esp. extreme ones, for variables with non-small scope. That should further remove ambiguity and make code more readable.
|Type||Old naming (convention)||Proposed|
|int||x1, x2, y1, y2||xmin, width, ymin, height|
Note that all these examples can be changed without touching DNA (afaics).
Ghost C++11 features
Ghost probably wouldn't benefit too greatly from modern C++ usage, but there are a few features that might be handy. Changes proposed here should move us closer to following the C++ guidelines: http://isocpp.github.io/CppCoreGuidelines/CppCoreGuidelines.
If in future we add more C++ to our UI code, we should follow the same rules.
- override, virtual and final keywords: Explicit usage of these terms in class hierarchies may prevent some errors. Especially override and final since they lead to a compile error on function signature mismatch (C.128).
- std::unique_ptr: It's considered good practise to use smart pointers (esp. std::unique_ptr) to manage lifetimes of C++ objects. They make object ownership explicit and enforce static sanity checks. (R.1, R.11, R.20). We may want to add our own make_unique() too, which is only available in C++17.
- default and delete constructors and destructors: Using these may help catch some errors at compile time, make classes more compatible with std containers and allows optimizations for trivial operation (e.g. a = default copy constructor makes a type "trivially copyable", which some containers and compilers optimize for) (C.43, C.80, C.81).
- In-class initializer: Among other reasons, making good use of in-class initialization reduces likelyhood of uninitialized members (C48, C.45).
- Range-based for loops: Ghost uses std containers in a few places. C++11 range-based for loops make iterating them far less verbose (ES.71).
- auto to avoid verbosity/redundancy: While there are good reasons to be sceptical about auto, there are few cases where they are definitely useful. For example in case of long type names (like std::vector<std::unique_ptr<SomeType>>::const_iterator). (ES.11)
- using over typedef: The using syntax to create aliases is often considered more readable. (T.43).
- nullptr: More on the esthetical side of things (although may avoid some nasty surprises!), but we should use standard nullptr instead of NULL. We can avoid including stddef.h everywhere then. (ES.47)
Other, similar improvements are possible. These are just a few examples of low hanging fruits.
- Introduce wrappers for commonly bundled variables (e.g. PointerRNA & PropertyRNA, wmOperatorType & PointerRNA, ScrArea & ARegion).
- Split up bigger, "generic" types. For example uiBut contains data that only applies to certain button-types. uiButTab is an example of how this can be avoided.
- Wrap related struct members into nested structs. E.g. rather than uiBut.editstr, uiBut.editval, uiBut.editvec, etc, it could be uiBut.edit_values.foo.
- Replace booleans in parameter lists with enums. Having a parameter list like foo(true, false, false) is cumbersome to use (what does each boolean mean) and leads to mistakes (using wrong order of booleans). It's better to be explicit what each value refers to by using enum types. Bitflags are also an option.
- Split big functions into more manageable chunks.
- Add const where applicable
- Of course improving naming, comments and documentation is always a good idea!