Page MenuHome

Quick Effects: Smoke and Fluid simulation does not work
Confirmed, NormalPublicKNOWN ISSUE

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2070/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 441.66

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: (optional)

Short description of error
Smoke and fire simulation just does not work in my specific hardware as per https://docs.blender.org/manual/en/latest/physics/introduction.html#bpy-ops-object-quick

Exact steps for others to reproduce the error
Default Cube, In object menu, hit Q: quick effects, select either of fluid and smoke. The external cube is made, but no effect is seen in animation.

Further, add Smoke, add fur, add smoke: it throws this in console (which I guess is expected) as well in a banner in blender (which can be shown in a better way):

Warning: Only one modifier of this type is allowed
Traceback (most recent call last):
  File "/Users/me/blender-build/build/bin/Debug/Blender.app/Contents/Resources/2.83/scripts/startup/bl_operators/object_quick_effects.py", line 480, in execute
    obj.modifiers[-1].fluid_type = 'FLOW'
AttributeError: 'ParticleSystemModifier' object has no attribute 'fluid_type'

location: <unknown location>:-1

Event Timeline

Ankit (ankitm) renamed this task from Smoke simulation does not work (RTX 2070 + core i5). to Quick Effects: Smoke and Fluid simulation does not work .Fri, Feb 14, 3:23 PM
Ankit (ankitm) updated the task description. (Show Details)

It don't work for me too

Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f

Exact steps for others to reproduce the error

1 Select the default cupe.
2 Go to the obejct droppdown menu and select the Qucik effect
3 Select smok and Blende rwill generate to container but then it wonr render any tihng.

Ankit (ankitm) changed the task status from Needs Triage to Confirmed.Fri, Feb 14, 3:30 PM
Ankit (ankitm) added a subscriber: Ankit (ankitm).

Can confirm on:
Operating system: Darwin-18.6.0-x86_64-i386-64bit 64 Bits
Graphics card: Intel(R) HD Graphics 6000 Intel Inc. 4.1 INTEL-12.9.22
Broken: version: 2.83 (sub 2), branch: master, commit date: 2020-02-14 05:14, hash: rBf621f03e4b25

Fur and explode work. smoke and liquid don't show anything despite checking "render .. " option in edit menu > Adjust last operation.

Ankit (ankitm) changed the task status from Confirmed to Needs Triage.Fri, Feb 14, 3:38 PM

You need to bake the simulation first now, manual is seemingly not updated for this yet.

cc: @Aaron Carlisle (Blendify)

Philipp Oeser (lichtwerk) claimed this task.

Smoke has to be baked first:

Or set your cache Type to Replay

https://docs.blender.org/manual/en/dev/physics/fluid/introduction.html#workflow
https://docs.blender.org/manual/en/dev/physics/fluid/type/domain/cache.html

Dont really see a bug here, closing. (feel free though to comment again if issue persist after having a valid cache)

P.S. for this one:

Further, upon using Fluid or smoke after Fur, it throws this in console

I cannot reproduce this, please open another report for this (since mixing multiple issues in a single report just makes it hard to process these effectively)

Aaron Carlisle (Blendify) reopened this task as Confirmed.Fri, Feb 14, 6:34 PM

I actually consider this a regression because quick effects are meant to be quick so we should set the cache to replay by default. See my patch here: D6853: Fix T73799: Quick Effects should show immidiate results

Aaron Carlisle (Blendify) changed the subtype of this task from "Report" to "Known Issue".