Page MenuHome

When rendering from command line, it says: not an anim
Closed, ResolvedPublic

Description

System Information
Operating system: Fedora 31 (5.4.18-200.fc31.x86_64)
Graphics card: GeForce MX150

Blender Version
Broken: 2.81

Short description of error
When rendering from command line, it can't load mp4 video and says: not an anim.

Exact steps for others to reproduce the error
Use a mp4 video as texture:
(Material Properties > Surface > Use Nodes > Surface: Emission > Color: Image Texture (import the mp4 video as texture))
When rendering from UI, every thing works as expected.
But when rendering from command line, it can't load the mp4 and says: not an anim.
The command I use for render is:
$ blender -b MyFile.blend -a

Please help me.
Thanks

Event Timeline

Are you using the official release downloaded from blender.org, or are you using the Fedora package?

The Blender version you used on the command line may be from the Fedora package, and perhaps it doesn't include certain codecs due to licensing issues.

Brecht Van Lommel (brecht) changed the task status from Needs Triage to Needs Information from User.Fri, Feb 14, 2:59 PM

Yes, you are right. The problem is related to fedora's package.
Thanks for your help

Reza Saberi Rad (RezaSR) closed this task as Resolved.Fri, Feb 14, 3:57 PM
Reza Saberi Rad (RezaSR) claimed this task.