Page MenuHome

UDIM glitches after switching modes
Confirmed, NormalPublicBUG

Description

System Information
Operating system: Windows-10-10.0.16299-SP0 64 Bits
Graphics card: GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.83 (sub 2), branch: master, commit date: 2020-02-13 23:33, hash: rB4af74f453d4e

Exact steps for others to reproduce the error

  • Open file. You can't pack UDIM textures so I zipped a folder.

  • There's a 'Texture Paint' mode in the right window. You can paint with no problem.

  • Undo. Switch to 'edit mode', switch back to 'paint mode'.
  • Now paint doesn't render properly.

Event Timeline

Marcin Twarowski (Tvaroog) renamed this task from UDIM glitches when going to edit mode to UDIM glitches after switching modes.Feb 14 2020, 4:35 PM
Marcin Twarowski (Tvaroog) created this task.
Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Feb 17 2020, 8:50 AM
Bastien Montagne (mont29) changed the subtype of this task from "Report" to "Bug".Feb 17 2020, 3:51 PM

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.83 (sub 8), branch: master, commit date: 2020-03-13 15:29, hash: rB110a35ef5a0e

I have almost the same problem.
My problem is easier to reproduce - no need to undo or switch mode
Exact steps for others to reproduce the error

  1. Create a sphere, make uv split to few Udims.
  2. Create Udim texture.
  3. go to paint mode and start paint it.
  4. zoom out or zoom in view . You will see it disappear when you zoom out.
  5. if you quit to object mode it will work properly.
  6. if you go back to paint mode it will work properly, but if you paint something new - this new paint will disappear when you zoom out.

It looks the same as in @Marcin Twarowski (Tvaroog) video example.