Page MenuHome

EEVEE: Screen Space Refraction Objects Not Rendering In Final Render when Subsurface Render Pass Enabled
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Linux-5.3.0-28-generic-x86_64-with-debian-buster-sid 64 Bits
Graphics card: Radeon RX Vega ATI Technologies Inc. 4.5.13581 Core Profile Context

Blender Version
Broken: version: 2.81, 2.81a, 282 (sub 16), branch: master, commit date: 2019-11-20 14:27, hash: rB26bd5ebd42e3
Worked: 2.80

Short description of error
Screen Space Refraction Objects Not Rendering In Final Render when Subsurface Render Pass Enabled

Exact steps for others to reproduce the error
When the next options are match, the objects with ssr materials are not drawn in a final render

  • One object needs to have a material with with the Screen Space Refraction option enabled.
  • One object needs to have a subsurface scattering bsdf.
  • Enable Screen Space Reflections in the Render tab
    • Enable Refraction in the Render tab
  • Enable Subsurface Direct or Subsurface Color in the viewlayer tab

Now when rendering (final image) the Glass shaded object will not be rendered. I assume that incorrect framebuffers are bound at that the time the reflections/refractions are calculated.

Event Timeline

Jeroen Bakker (jbakker) changed the task status from Needs Triage to Confirmed.Feb 17 2020, 9:46 AM
Jeroen Bakker (jbakker) claimed this task.
Jeroen Bakker (jbakker) created this task.
Jeroen Bakker (jbakker) changed the subtype of this task from "Report" to "Bug".

Issue found during development of T72007: Design: EEVEE Compositing added a new report as it was introduced along the way and seems to be easier to fix in master, than in the T72007 branch

Jeroen Bakker (jbakker) triaged this task as High priority.Feb 17 2020, 10:47 AM
Jeroen Bakker (jbakker) edited projects, added BF Blender (2.83); removed BF Blender.

Found differences during rendering

  • Issue is that the SSS render pass changes the opaque refraction pass (refract_pass). Will check with @Clément Foucault (fclem) for a good solution

https://developer.blender.org/P1259

At this point there are some render artifacts when using SSS+SSR together. These artifacts are that the SSS masking based on Stencils are rendering hard edges

After long pair bugfixing @Clément Foucault (fclem) accepted this change. We can improve in the future, but this code wasn't needed anymore since the shadow map refactoring.
We added this to D6331

Jeroen Bakker (jbakker) closed this task as Resolved.Feb 21 2020, 11:23 AM

This issue is resolved by committing D6331