Page MenuHome

In editing mode, when "in Front" is on, Annotations are not drawn on the surface
Closed, ResolvedPublicBUG

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 550 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 376.54

Blender Version
Broken: version: 2.83 (sub 4), branch: master, commit date: 2020-02-17 14:03, hash: rBe64166652b17
Worked: (optional)

Short description of error
In editing mode, when "in Front" is on, Annotations are not drawn on the surface.
You will see like in the video below the lines are not the surface.

Exact steps for others to reproduce the error

  1. Open Attached File
  2. With annotations tool enabled, try to draw a line on the cube surface
  3. Uncheck the "in Front" box and draw again

The first time does not work.

Event Timeline

This is not an addon problem. This is a Blender problem. In editing mode, when "in Front" is on, Annotations are not drawn on the surface. In this mode Annotation are snapped to the origin, although surface painting is selected.

Germano Cavalcante (mano-wii) renamed this task from Addon: Bsurface ignores annotation line when in front is activated to In editing mode, when "in Front" is on, Annotations are not drawn on the surface.Feb 18 2020, 2:06 PM
Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Confirmed.
Germano Cavalcante (mano-wii) updated the task description. (Show Details)
Germano Cavalcante (mano-wii) changed the subtype of this task from "Report" to "Bug".
Jeroen Bakker (jbakker) closed this task as Resolved.Mar 17 2020, 1:59 PM
Jeroen Bakker (jbakker) claimed this task.

Unable to reproduce anymore in latest master but detected an assert. I fixed the assert by rB8cb463f4ff24: OverlayEngine: crash when using hidden faces

Please try the latest daily build: https://builder.blender.org/download/

If the problem persists, please let us know so we can re-open the report. Don't forget to mention the specific version you tested again.

This bug is kind of a bouncing ball, now drawing annotation on the surface is working in edit mode, but if you activate bsurface the mesh is bouncing away from the initial place. @Jeroen Bakker (jbakker) Please give me few days to play with this i will come back to you. @Vladimir Spivak (cwolf3d) can try it with the latest master and put bsurface on.

I tested it on master, commit date: 2020-03-17 18:02, hash: rBe09f0caff32e

Here is my state of affair in video :)