Page MenuHome

Subframes still bad when used with 'Fire & Smoke' or 'Fire' emitters. (both mesh & particle)
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1070 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 431.86

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: (optional)

Short description of error
[Moving emitters still produce 'blocky' trails if used on moving 'Fire' or 'Fire and Smoke' emitters.]

Exact steps for others to reproduce the error
[Bake the attached .blend and observe the results.
Here's the blend-

Basically the same file as used in T70175, with the emitters duplicated and changed to 'fire' and 'fire and smoke', I re-baked it as shown below, with the emitters changed to 'Fire' and 'Fire and Smoke' types, after seeing the comment from @SlyNine (SlyNine) in T70175.

And here's what it looks like-

Doesn't look like any of those emitters are doing terribly much with the 200 subframes all of them are set to.

And it does not look anywhere near as smooth as the 'smoke' only emitter results (the reason why T70175 was closed)-

That's the same scene uploaded above, but with all the emitters set to 'smoke' only type emitters.
]
[Based on the default startup or an attached .blend file (as simple as possible)]

Event Timeline

Mark Spink (marks) added a comment.EditedFeb 19 2020, 1:31 AM

Interestingly, there's a visible difference between 2.82 release and 2.83 Alpha-

Same scene as uploaded above, but re-baked in 2.83 alpha: this version-

I'd say it's still not as good as 'smoke' only emitters, but definitely better than 2.82 release version for 'fire' and 'fire and smoke' emitters, significantly more-so for the particle emitters (both foreground emitters).

Just for fun I set this up. But you can tell when it starts spinning fast the fire is skipping.

Germano Cavalcante (mano-wii) changed the task status from Needs Triage to Needs Information from User.Feb 20 2020, 1:11 PM

I cannot reproduce the problem. Even reducing the number of subframes to 1 and increasing the speed of the particles 10 times.
Can we consider this problem as already solved in the last builds?
https://builder.blender.org/download/

Mark Spink (marks) added a comment.EditedFeb 20 2020, 11:22 PM

I'd say it's not even working 'properly' for smoke, now you've made me look at it again-

Baked in this version: 2.83 (sub 4), branch: master, commit date: 2020-02-20 12:28, hash: rBd95e9c7cf80a Fresh off the downloads page.

As you can clearly see from this simulation, subframes seem to work for one single frame, say frame 1 to frame 1+100 subframes, then break on the transition to the next frame and it's 100 subframes.
Then subframes work again, for the duration of frame 2, then break again at frame 3, etc. etc.

I'm sure you agree that the example here is simple enough: a single mesh emitter being rotated by a single empty, here's the blend file-

So either 'subframes' doesn't work as one would expect, or 'constant' interpolation on keyframes is broken (used to rotate the sphere), I'd say it's subframes though.

I'd say it's not even working 'properly' for smoke, now you've made me look at it again-

Baked in this version: 2.83 (sub 4), branch: master, commit date: 2020-02-20 12:28, hash: rBd95e9c7cf80a Fresh off the downloads page.

As you can clearly see from this simulation, subframes seem to work for one single frame, say frame 1 to frame 1+100 subframes, then break on the transition to the next frame and it's 100 subframes.
Then subframes work again, for the duration of frame 2, then break again at frame 3, etc. etc.

I'm sure you agree that the example here is simple enough: a single mesh emitter being rotated by a single empty, here's the blend file-

So either 'subframes' doesn't work as one would expect, or 'constant' interpolation on keyframes is broken (used to rotate the sphere), I'd say it's subframes though.

Did you try increasing the subframes in the domain? If I understand correctly there's the subframes for the inflow object but you'll need to increase the subframes in the domain as well.

I'll try later when I get a chance.

Mark Spink (marks) added a comment.EditedFeb 21 2020, 4:19 AM

I see what you mean @SlyNine (SlyNine) ! In that case, it looks like the 'use adaptive time steps' setting in the domain is not terribly adaptive! As in, it only does the 'minimum time steps' value in this instance, it does not seem to 'adapt'.

@Germano Cavalcante (mano-wii) I will close this bug closed and create a different one for the 'use adaptive time steps' not really 'adapting', but just doing what you set as a minimum number of time steps.

Mark Spink (marks) closed this task as Resolved.Feb 21 2020, 4:21 AM