Page MenuHome

Smoke flow force field not working with Mantaflow Gas
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 950M/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: (optional)

Short description of error
I'm making a smoke simulation with Blender 2.82 and I'm trying to guide a particle system with a smoke flow field (like this video: https://www.youtube.com/watch?v=iddFzef4H6E). Both normal velocity and gravity are in 0 but particles don't move at all. Should I change something else with the new simulation framework?

Exact steps for others to reproduce the error
Create a smoke simulation, create an object with a particle system with both normal velocity and gravity field weight with a value of 0, create a smoke flow force field with the smoke domain object of the smoke simulation

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Confirmed.Feb 21 2020, 8:23 PM

Did you try to change the Flow Source in the Flow settings?
https://docs.blender.org/manual/en/2.80/physics/smoke/types/flow_object.html#flow-source

This does not appear to be a bug.
For user support please use other channels:
https://www.blender.org/community/

Richard Antalik (ISS) reopened this task as Needs Information from User.Feb 21 2020, 8:33 PM

Oops, confirmed wrong report.

I see some dependency cycle in the file, so it would be best to resolve that.

Also it is not evident what does not work in this report. Is it particle system or force field?

Richard Antalik (ISS) closed this task as Invalid.Feb 21 2020, 8:35 PM

Ok I will change this again...

If you can demonstrate bug with simple case that would be acceptable. it is hard to debug complex solutions like this one

@Germano Cavalcante (mano-wii) I'm not sure I should change the flow source. I changed it to the particle system but it didn't work either. @Richard Antalik (ISS) What it not working is the particle system. Normally with a smoke flow force field the particles shoud follow the smoke direction but they don't.

Like this example: https://www.youtube.com/watch?v=Xkxvye9xA8o I woudn't know how to simplify the case

@Germano Cavalcante (mano-wii) I'm not sure I should change the flow source. I changed it to the particle system but it didn't work either...

Did you delete the cache?

@Pierre Puentes (pierreee1) sorry for misunderstanding I understand what problem is now

@Germano Cavalcante (mano-wii) I have deleted the cache, and it works if you don't start from frame 1, but only once. Does playing simulation for second time work for you?

@Germano Cavalcante (mano-wii) I didn't delete it bit I changed the cache's type to Replay and it works but with very strange results. @Richard Antalik (ISS) Using Modular type and deleting the cache also works once if I don't start from frame 1.

@Pierre Puentes (pierreee1) sorry for misunderstanding I understand what problem is now

@Germano Cavalcante (mano-wii) I have deleted the cache, and it works if you don't start from frame 1, but only once. Does playing simulation for second time work for you?

I was unable to replicate this problem here. (The baking works with the initial frame being 1, 2, 10 ...)

I’ll try making another sim from scratch. What steps did you take? Also, did you delete the whole cache folder?

Sill no luck @Germano Cavalcante (mano-wii) @Richard Antalik (ISS) and I tried in a different machine:

With the Modular and Final type of cache the particles don't move, even if I make a change in the simulation domain settings and the smoke flow force field and re-bake the simulation nothing happens.

When I use the Replay type of cache the particles move but don't follow the smoke as they should.

Richard Antalik (ISS) reopened this task as Confirmed.Feb 26 2020, 6:45 PM

I will re-open this, because I have still problems even when starting from scratch.

Can someone please answer this and stop complaining about it being vague? particles don't follow mantaflow smoke, pretty simple question and it's not working for me either - same tutorial

Report is confirmed so we need developer to go over this now. I apologize for delaying this, but please be patient.

This problem seems to be still around, tried the same with the other guys, same result. Particles don't follow the smoke..

@Germano Cavalcante (mano-wii) If I'm understanding you, you've been able to get this working, correct? Would you be able to upload a sample blender file and instructions for reproduction? I've not been able to have Mantaflow smoke be affected by a particle force field, regardless of cache type or re-baking.

I also reported this bug, merged here, didn't know about this report... sorry. I just want to tell my experience with this "inconsistency" in the smoke flow force field.
1 - While baking the smoke sim with replay cache mode the smoke flow force field seems to work ok(but I still find something strange... it's hard to set up and make it work well but this is another thing separated from the problem from this report...)


2 - After the smoke sim is cached and you change some of the settings from the smoke flow force field the inconsistency is apparent, the particles become totally different and even when you set the values back to where they are before the result from case 1 never came back... you need to clear the smoke cache and simulate again...

  • open the attached file;
  • start the playback and see the "right result" of particles motion advected by the smoke through the smoke flow force field;
  • after the smoke sim is cached try to change any value from the smoke flow force field like strength... the result is not anymore related to the smoke... and even bring the value back the result is different...

I also started a discussion about "exposing"(I'm not dev and don't know if it's a simple "expose" case) more properties from gas sim to be used by the smoke flow force field.
You can check it here:
https://devtalk.blender.org/t/update-smoke-flow-force-field/12761

Well I found a very handy feature while investigating this bug and it's the viewport display setting inside mantaflow domain. The Debug Velocity option reveals that the velocity is calculated while the simulation runs but this information seems to be "released" or "cleaned" after the the smoke frames are baked.

While baking (Replay Mode)

After bake (Replay Mode)

Is there a way to store the velocity info with the cache?

Nice observation! This is indeed weird, because the velocity is also stored in the cache folder (if you see the cached data on the computer, there are velocity frames saved). Also in the shading process, the velocity data are not there either. Maybe @Sebastián Barschkis (sebbas) can explain us why this is happening? Could be to make the bakes lighter?

Any news on this report? Is Someone checking here?

@Everton Schneider (eversimo) That's a good point - the velocities are currently not loaded when reading the cache. I probably omitted them for optimization purposes. Will fix that!

@Sebastián Barschkis (sebbas) Do you think that it is possible to keep the velocity data in the cache(I don't know exactly how it works so ignore my guessing)?
Also, what do you think that is causing the strange behavior with the smoke flow force field over particles? Do you know how to bring a similar behavior as before(old smoke system) or even better as discussed here?
Or the smoke force field behavior is a separate issue here?

This is awesome! I can't express how nice is this... to be able to follow a bug begin smashed! Everything is working so nice now! Thank you all!!! Special thanks to @Sebastián Barschkis (sebbas) ! You're doing an awesome job! Thanks!