Page MenuHome

2.82 Mantaflow not writing cache files (unicode characters in filepath)
Closed, ResolvedPublic

Description

System Information
Operating system: Windows-10-10.0.18362-SP0 64 Bits
Graphics card: GeForce GTX 1080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 442.19
CPU: Threadripper 1950X
RAM : 32GB

Blender Version
Broken: version: 2.82 (sub 7), branch: master, commit date: 2020-02-12 16:20, hash: rB77d23b0bd76f
Worked: (optional)

Short description of error
When baking a fluid sim (fluid or gas), no files are written to the cache directory. Folders like data and config are created but no actual cache files. Simulation works in "replay" mode.
Weird issue/ bug since it worked on my home pc but not on the work pc. No errors reported by blender.

Exact steps for others to reproduce the error

  1. Scale cube up, Apply transform, Make fluid "domain".
  2. Create sphere and make fluid "flow".
  3. Set cache directory in domain.
  4. Cache the sim.
  5. Look inside the cache directory or try scrubbing the timeline.

Event Timeline

Richard Antalik (ISS) changed the task status from Needs Triage to Needs Information from User.Feb 24 2020, 7:58 PM

Is it possible, that your work PC has some restrictions on users? Can you try run Blender as admin?

It is hard to debug this if you can not create 100% reproducible case

Does this happen in any folder location? (or does it work if you choose a cache directory somewhere else? e.g. subfolder of the current .blend file?)
And just to make sure: please share you example .blend file (this makes sure we are all looking at the same thing...)

Is it possible, that your work PC has some restrictions on users? Can you try run Blender as admin?

It is hard to debug this if you can not create 100% reproducible case

I can't see how the PC would have any special restrictions as I personally installed windows from scratch. It is set up as an "organization pc" during setup though.
I have tried running it as admin and it makes no difference.

Does this happen in any folder location? (or does it work if you choose a cache directory somewhere else? e.g. subfolder of the current .blend file?)
And just to make sure: please share you example .blend file (this makes sure we are all looking at the same thing...)

It works in the standard temp folder (AppData\Local\Temp\blender_a22300\cache_fluid) but if I change the directory to a folder on the desktop, documents, videos etc, it won't write any cache files anymore. I have tried setting the path as a relative path to the .blend file with no success. I have also tried rendering to the same folder and the render does output files to the folder.

Heres a simple example file as requested:

Update:
Tried the example file on a coworkers computer and everything works for him, the sim writes the cache files like it should.
I can get it to work by choosing our office NAS as the cache directory. So it works in %appdata% and on network drives but not in documents, videos, desktop etc.
Is there a better debug console that I can use to see what mantaflow is doing or trying to do while baking? Example like a "calculating x..... writing frame cache to directory x....." ?

I'm having the exact same problem. Other simulation caches are writing fine on the disk, but not Mantaflow.

I'm having the exact same problem. Other simulation caches are writing fine on the disk, but not Mantaflow.

Hi, I have solved the issue and it came down to my C:\Users\{username} having non-unicode characters (The Å in my last name). From the looks of your name here I would guess your Ş or ü might be your problem.
Updating my Windows username and replacing the Å with an A fixed the problem completely and Blender and Mantaflow are now writing out cache files to any directory I choose.
Updating the windows username path is not super easy but this guide made it less of a headache: https://winaero.com/blog/rename-user-profile-folder-windows-10/

DEVS: Maybe look into how Mantaflow handles non-unicode characters in file paths as Blender (Cycles/ Eevee) seems to handle it fine.

Philipp Oeser (lichtwerk) changed the task status from Needs Information from User to Needs Information from Developers.Feb 27 2020, 2:37 PM
Philipp Oeser (lichtwerk) renamed this task from 2.82 Mantaflow not writing cache files to 2.82 Mantaflow not writing cache files (unicode characters in filepath).Feb 27 2020, 2:38 PM

@Richard Antalik (ISS): that commit is two years old (I just posted this as a reference)
Report is from a version two weeks old and on a 64bit windows... Are you sure this is fixed (or a duplicate)?

Philipp Oeser (lichtwerk) reopened this task as Needs Information from Developers.Feb 27 2020, 3:16 PM

Sorry, I haven't checked. I was quite certain, that this issue was dealt with recently.

In any case I tested 2.82 with cache path //ščřž/ it didn't work.
2.83 did work.

Philipp Oeser (lichtwerk) closed this task as Resolved.Feb 27 2020, 3:57 PM
Philipp Oeser (lichtwerk) claimed this task.

@Richard Antalik (ISS), thx for getting back.
Looks like this was indeed fixed, see T73770: Mantaflow is unable to bake fluid simulations on non-ASCII file paths, rB4453509d83dc: Fix T73770: Mantaflow is unable to bake fluid simulations on non-ASCII file…, rBb8af5e10620f: Fluid: Updated manta pp files.

Sorry for the noise.

@Gustav Mårdestam (Carrotcakee): please try a fresh build from https://builder.blender.org/download/ (these have the fixes included).
Will close as resolved then, feel free to comment again if issues persist...