Page MenuHome

Blender freezes OS X
Closed, ResolvedPublic

Description

System Information
Operating system: OS X 10.14.6
Graphics card: Intel Ires Pro Graphics 6200 1536 MB

Blender Version
Broken: 2.8.2 & 2.8.3 alpha

Blender randomly freezes the entire OS. I launched Blender with debugging param through the command line for any clues.

I get this before the freeze.

Skipping auto-save, modal operator running, retrying in ten seconds...
Skipping auto-save, modal operator running, retrying in ten seconds...
Skipping auto-save, modal operator running, retrying in ten seconds...
Info: Saved "Hverticillata.blend"
Skipping auto-save, modal operator running, retrying in ten seconds...
Skipping auto-save, modal operator running, retrying in ten seconds...
Skipping auto-save, modal operator running, retrying in ten seconds...
Info: Saved "Hverticillata.blend"

Solution
I disable auto-save and haven't had any problems since.

Event Timeline

Ankit (ankitm) changed the task status from Needs Triage to Needs Information from User.Tue, Mar 3, 4:00 PM
Ankit (ankitm) added a subscriber: Ankit (ankitm).
  • Please run mv ~/Library/Application\ Support/Blender ~/Desktop & retry.

Thanks. Seems to be working with auto-save on. I notice random split second freezes but not permanent ones like before.

Ankit (ankitm) closed this task as Resolved.Wed, Mar 4, 9:07 AM
Ankit (ankitm) claimed this task.

My OS X froze again while I was texture painting. Maybe it's just my computer but I'll leave auto saving off for a while to see if the issue reappears.

I think I found the problem if anybody else is running into this issue. Do not check 'emulate 3 button mouse' with your Apple mouse. It will lock up your Mac.

Ankit (ankitm) reopened this task as Needs Triage.Wed, Mar 18, 7:07 PM

reopening to verify if it's a bug with Blender and Apple mouse for some reason, auto save.

Ankit (ankitm) changed the task status from Needs Triage to Needs Information from User.EditedWed, Mar 18, 7:10 PM

Could you add the steps to redo the bug ?
P.S. It'll probably stay in needs dev to redo if the mouse isn't available

Ankit (ankitm) closed this task as Invalid.Thu, Mar 26, 12:52 PM
Minh Truong (mistergreen) changed the task status from Invalid to Resolved.Thu, Mar 26, 4:29 PM

To reproduce this bug.
Check 'emulate 3 button' mouse in Input preference.
Use the Apple mouse, click, move, and scroll, zoom, quickly.